Bug 1651432 - v2v - support for -insecure option to support OSP SSL connection for VM migrations
Summary: v2v - support for -insecure option to support OSP SSL connection for VM migra...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.7
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard: V2V
Depends On: 1621895
Blocks: 1651500
TreeView+ depends on / blocked
 
Reported: 2018-11-20 04:55 UTC by Brett Thurber
Modified: 2019-08-06 12:45 UTC (History)
9 users (show)

Fixed In Version: libguestfs-1.40.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1651500 (view as bug list)
Environment:
Last Closed: 2019-08-06 12:44:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:2096 None None None 2019-08-06 12:45:14 UTC

Description Brett Thurber 2018-11-20 04:55:21 UTC
Description of problem:
Currently there is no support for OSP SSL connectivity when migrating VM's from a source.

Version-Release number of selected component (if applicable):
virt-v2v-1.38.2-12.22.lp.el7ev.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Using IMS tooling, initiating a migration for an OSP provider that is configured with SSL or SSL without validation, VM migration fails.
2.
3.

Actual results:
Using SSL for OSP as a provider VM migration fails.

Expected results:
Support for SSL connection for OSP to support VM migration.

Additional info:

Comment 2 Richard W.M. Jones 2018-11-20 08:45:58 UTC
Posted:
https://www.redhat.com/archives/libguestfs/2018-November/msg00176.html

Comment 3 Richard W.M. Jones 2018-11-20 10:05:27 UTC
v2 posted:
https://www.redhat.com/archives/libguestfs/2018-November/msg00187.html

In v2 the virt-v2v flag becomes:

  virt-v2v -o openstack -oo verify-server-certificate=false

Comment 4 Richard W.M. Jones 2018-11-20 10:26:09 UTC
v3 which works slightly differently:
https://www.redhat.com/archives/libguestfs/2018-November/msg00188.html

This would be back to ‘-oo insecure’ as in v1.

Comment 5 Richard W.M. Jones 2018-11-20 16:15:02 UTC
Upstream in:

https://github.com/libguestfs/libguestfs/commit/07d1d946be16ba035ec1857c183635e2961aa506
https://github.com/libguestfs/libguestfs/commit/a4f83ee6a439024fbbf22a73fa08285033a8172e

Note the wrapper will need to use:

-oo verify-server-certificate=false

Comment 6 Richard W.M. Jones 2018-11-21 10:50:04 UTC
Patch included in RHEL 7.6-LP
libguestfs-1.38.2-12.el7_6.1.24.lp.el7

Comment 7 Pino Toscano 2019-01-17 11:50:06 UTC
This bug will be fixed by the rebase scheduled for RHEL 7.7, see bug 1621895.

Comment 9 Ido Ovadia 2019-01-23 13:17:03 UTC
Verified
========
CFME 5.10.0.32
libguestfs-1.38.2-12.28.lp.el7ev.x86_64

Comment 11 mxie@redhat.com 2019-03-01 10:42:50 UTC
Test the bug with builds:
virt-v2v-1.40.2-1.el7.x86_64
libguestfs-1.40.2-1.el7.x86_64
libvirt-4.5.0-10.el7_6.6.x86_64
qemu-kvm-rhev-2.12.0-18.el7_6.3.x86_64
nbdkit-1.8.0-1.el7.x86_64


Steps:
1.Check option -oo verify-server-certificate=false/true in virt-v2v man page
#man virt-v2v
....
       -oo verify-server-certificate
       -oo verify-server-certificate="true|false"
           For -o openstack (virt-v2v-output-openstack(1)) only, this can be used to disable SSL certification
           validation when connecting to OpenStack by specifying -oo verify-server-certificate=false.


2.Install python2-openstackclient on the openstack guest where virt-v2v is running and copy keystone_admin from openstack root directory, then source keystone_admin
#yum install python2-openstackclient
#source keystone_admin


3.Convert a guest from VMware to openstack with option -oo verify-server-certificate=false

3.1 #  virt-v2v -ic vpx://root@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io  vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA -n default esx6.7-rhel6.10-x86_64 --password-file /tmp/passwd -o openstack -oo server-id=rhel7.6-mxie -oo verify-server-certificate=false
[   1.8] Opening the source -i libvirt -ic vpx://root@10.73.73.141/data/10.73.75.219/?no_verify=1 esx6.7-rhel6.10-x86_64 -it vddk  -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA
[   3.7] Creating an overlay to protect the source from being modified
[   7.2] Opening the overlay
virt-v2v: error: libguestfs error: could not create appliance through 
libvirt.

Try running qemu directly without libvirt using this environment variable:
export LIBGUESTFS_BACKEND=direct

Original error from libvirt: internal error: qemu unexpectedly closed the 
monitor: 2019-02-28 09:33:22.124+0000: Domain id=1 is tainted: custom-argv
2019-02-28T09:33:22.325340Z qemu-kvm: -drive 
file=/var/tmp/v2vovlfc2f94.qcow2,format=qcow2,if=none,id=drive-scsi0-0-0-0,cache=unsafe,copy-on-read=on,discard=unmap: 
Could not open backing file: Failed to connect socket 
/var/tmp/vddk.w8yiNg/nbdkit0.sock: Permission denied [code=1 int1=-1]

If reporting bugs, run virt-v2v with debugging enabled and include the 
complete output:

  virt-v2v -v -x [...]

3.2 Set direct for LIBGUESTFS_BACKEND
#export LIBGUESTFS_BACKEND=direct

3.3 #  virt-v2v -ic vpx://root@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io  vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA -n default esx6.7-rhel6.10-x86_64 --password-file /tmp/passwd -o openstack -oo server-id=rhel7.6-mxie -oo verify-server-certificate=false
[   1.9] Opening the source -i libvirt -ic vpx://root@10.73.73.141/data/10.73.75.219/?no_verify=1 esx6.7-rhel6.10-x86_64 -it vddk  -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA
[   3.8] Creating an overlay to protect the source from being modified
[   7.2] Opening the overlay
[  67.8] Inspecting the overlay
[ 147.6] Checking for sufficient free disk space in the guest
[ 147.6] Estimating space required on target for each disk
[ 147.6] Converting Red Hat Enterprise Linux Server release 6.10 (Santiago) to run on KVM
virt-v2v: warning: guest tools directory ‘linux/el6’ is missing from 
the virtio-win directory or ISO.

Guest tools are only provided in the RHV Guest Tools ISO, so this can 
happen if you are using the version of virtio-win which contains just the 
virtio drivers.  In this case only virtio drivers can be installed in the 
guest, and installation of Guest Tools will be skipped.
virt-v2v: This guest has virtio drivers installed.
[1995.2] Mapping filesystem data to avoid copying unused and blank areas
[2008.6] Closing the overlay
[2015.6] Assigning disks to buses
[2015.7] Checking if the guest needs BIOS or UEFI to boot
[2015.7] Initializing the target -o openstack
Failed to set volume read-only access mode flag: Invalid volume: Volume 61573e31-de0f-4281-8a22-3fb4e48d2e37 status must be available to update readonly flag, but current status is: creating. (HTTP 400) (Request-ID: req-13356ac0-3cb1-4707-acae-e9adf0ddfc7a)
[2048.5] Copying disk 1/1 to /dev/disk/by-id/virtio-61573e31-de0f-4281-8 (raw)
    (100.00/100%)
[2434.6] Creating output metadata
[2452.2] Finishing off

3.4 Launch the volume as instance in openstack GUI interface,, Check points for guest are passed


4.Convert a windows guest from VMware to openstack with option -oo verify-server-certificate=true

4.1 Also need to set direct for LIBGUESTFS_BACKEND
#export LIBGUESTFS_BACKEND=direct

4.2 # virt-v2v -ic vpx://root@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io  vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA -n default esx6.7-win2016-x86_64 --password-file /tmp/passwd -o openstack -oo server-id=rhel7.6-mxie -oo verify-server-certificate=true -v -x |& tee > openstack_invalid_volume.log

4.3 Also there is error info "Failed to set volume...."
# cat openstack_invalid_volume.log |grep -i "Failed to set"
Failed to set volume read-only access mode flag: Invalid volume: Volume 009dc6bd-2f80-4ac3-b5e7-771863aca237 status must be available to update readonly flag, but current status is: creating. (HTTP 400) (Request-ID: req-6f56ce4c-249b-4112-9c52-dd91b7f5aae9)

4.4 Launch the volume as instance in openstack GUI interface, Check points for guest are passed


5.Convert a guest which has multiple disks from VMware to openstack with option -oo verify-server-certificate without value
5.1 # virt-v2v -ic vpx://root@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io  vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA -n default esx6.7-rhel7.5-multi-disks --password-file /tmp/passwd -o openstack -oo server-id=rhel7.6-mxie -oo verify-server-certificate
[  11.6] Opening the source -i libvirt -ic vpx://root@10.73.73.141/data/10.73.75.219/?no_verify=1 esx6.7-rhel7.5-multi-disks -it vddk  -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA
[  29.4] Creating an overlay to protect the source from being modified
[  56.6] Opening the overlay
[ 237.1] Inspecting the overlay
[ 357.7] Checking for sufficient free disk space in the guest
[ 357.7] Estimating space required on target for each disk
[ 357.7] Converting Red Hat Enterprise Linux Server 7.5 (Maipo) to run on KVM
virt-v2v: warning: guest tools directory ‘linux/el7’ is missing from 
the virtio-win directory or ISO.

Guest tools are only provided in the RHV Guest Tools ISO, so this can 
happen if you are using the version of virtio-win which contains just the 
virtio drivers.  In this case only virtio drivers can be installed in the 
guest, and installation of Guest Tools will be skipped.
virt-v2v: This guest has virtio drivers installed.
[3257.7] Mapping filesystem data to avoid copying unused and blank areas
[3606.0] Closing the overlay
[3651.5] Assigning disks to buses
[3651.6] Checking if the guest needs BIOS or UEFI to boot
[3651.7] Initializing the target -o openstack
Failed to set volume read-only access mode flag: Invalid volume: Volume 80021cbb-0af8-4452-9d89-e7ce3ca3fa36 status must be available to update readonly flag, but current status is: creating. (HTTP 400) (Request-ID: req-63aecb91-8d2c-401d-8fca-52e4028a6e76)
Failed to set volume read-only access mode flag: Invalid volume: Volume 90dbad02-ace1-451a-9932-3ec8cf0b2df7 status must be available to update readonly flag, but current status is: creating. (HTTP 400) (Request-ID: req-e9f64626-2f67-4847-a29e-9df12cbc2893)
Failed to set volume read-only access mode flag: Invalid volume: Volume 610a9e95-b0eb-41a7-81e2-f32e57fc157d status must be available to update readonly flag, but current status is: creating. (HTTP 400) (Request-ID: req-0114cd46-97ba-45ee-9840-1acec94ab7c7)
Failed to set volume read-only access mode flag: Invalid volume: Volume 923bac05-966a-4b7a-b832-d0904f5244c0 status must be available to update readonly flag, but current status is: creating. (HTTP 400) (Request-ID: req-c43d6eed-54aa-4cc6-939e-779ee6112699)
[3817.5] Copying disk 1/4 to /dev/disk/by-id/virtio-80021cbb-0af8-4452-9 (raw)
    (100.00/100%)
[4215.6] Copying disk 2/4 to /dev/disk/by-id/virtio-90dbad02-ace1-451a-9 (raw)
    (100.00/100%)
[4572.1] Copying disk 3/4 to /dev/disk/by-id/virtio-610a9e95-b0eb-41a7-8 (raw)
    (100.00/100%)
[5066.0] Copying disk 4/4 to /dev/disk/by-id/virtio-923bac05-966a-4b7a-b (raw)
    (100.00/100%)
[5535.3] Creating output metadata
[5592.5] Finishing off

5.2 Launch the volume as instance in openstack GUI interface, Check points for guest are passed

6.Convert a guest s from VMware to openstack with option -oo verify-server-certificate with wrong value
# virt-v2v -ic vpx://root@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io  vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA -n default esx6.7-win2016-x86_64 --password-file /tmp/passwd -o openstack -oo server-id=rhel7.6-mxie -oo verify-server-certificate=wrong
virt-v2v: error: internal error: invalid argument: bool_of_string

If reporting bugs, run virt-v2v with debugging enabled and include the 
complete output:

  virt-v2v -v -x [...]




Hi rjones,
   "-o openstack" conversion can be finished successfully with -oo verify-server-certificate=true/false/empty, but I have some questions:
1.Need to set environment variable "export LIBGUESTFS_BACKEND=direct" during -o openstack conversion, is it expected result as v2v doesn't need to set this during -o glance conversion ?
2.Will show below info during -o openstack conversion no matter if adding option verify-server-certificate, pls help to check the log "openstack_invalid_volume"
"Failed to set volume read-only access mode flag: Invalid volume: Volume 80021cbb-0af8-4452-9d89-e7ce3ca3fa36 status must be available to update readonly flag, but current status is: creating. (HTTP 400) (Request-ID: req-63aecb91-8d2c-401d-8fca-52e4028a6e76)
3.Check"-oo verify-server-certificate" option in v2v man page, there are two lines but the first line seems unnecessary. Because -oo verify-server-certificate=true is default option (the default is to verify the server certificate), but I didn't find relevant illustration, I think adding this in second line would be more easier to understand for customer.

#man virt-v2v
....
       -oo verify-server-certificate
       -oo verify-server-certificate="true|false"

Thanks

Comment 12 Richard W.M. Jones 2019-04-09 09:36:21 UTC
> 1.Need to set environment variable "export LIBGUESTFS_BACKEND=direct" during -o openstack conversion, is it expected result as v2v doesn't need to set this during -o glance conversion ?

No this is a bug, but please file it separately.

> 2.Will show below info during -o openstack conversion no matter if adding option verify-server-certificate, pls help to check the log "openstack_invalid_volume"
"Failed to set volume read-only access mode flag: Invalid volume: Volume 80021cbb-0af8-4452-9d89-e7ce3ca3fa36 status must be available to update readonly flag, but current status is: creating. (HTTP 400) (Request-ID: req-63aecb91-8d2c-401d-8fca-52e4028a6e76)

This is also a new bug.

> 3.Check"-oo verify-server-certificate" option in v2v man page, there are two lines but the first line seems unnecessary. Because -oo verify-server-certificate=true is default option (the default is to verify the server certificate), but I didn't find relevant illustration, I think adding this in second line would be more easier to understand for customer.

This seems fine to me.  Using -oo verify-server-certificate sets the flag to true.  That may be
the default, but someone might prefer to set it explicitly.

Comment 13 mxie@redhat.com 2019-04-09 13:11:18 UTC
(In reply to Richard W.M. Jones from comment #12)
> > 1.Need to set environment variable "export LIBGUESTFS_BACKEND=direct" during -o openstack conversion, is it expected result as v2v doesn't need to set this during -o glance conversion ?
> 
> No this is a bug, but please file it separately.

Sorry, I didn't describe the problem clearly.

If convert a guest to glance on v2v conversion server which is not conversion appliance on openstack, there is no need to set environment variable "export LIBGUESTFS_BACKEND=direct" during conversion

But if convert a guest to glance by v2v conversion server which is conversion appliance on openstack, need to set environment variable "export LIBGUESTFS_BACKEND=direct" during conversion

If convert a guest to openstack by v2v conversion server which is conversion appliance on openstack, need to set environment variable "export LIBGUESTFS_BACKEND=direct" during conversion whatever verify-server-certificate sets

> > 2.Will show below info during -o openstack conversion no matter if adding option verify-server-certificate, pls help to check the log "openstack_invalid_volume"
> "Failed to set volume read-only access mode flag: Invalid volume: Volume
> 80021cbb-0af8-4452-9d89-e7ce3ca3fa36 status must be available to update
> readonly flag, but current status is: creating. (HTTP 400) (Request-ID:
> req-63aecb91-8d2c-401d-8fca-52e4028a6e76)
> 
> This is also a new bug.

Already filed bug1685081 for this issue

Comment 14 Richard W.M. Jones 2019-04-09 14:02:29 UTC
(In reply to mxie@redhat.com from comment #13)
> (In reply to Richard W.M. Jones from comment #12)
> > > 1.Need to set environment variable "export LIBGUESTFS_BACKEND=direct" during -o openstack conversion, is it expected result as v2v doesn't need to set this during -o glance conversion ?
> > 
> > No this is a bug, but please file it separately.
> 
> Sorry, I didn't describe the problem clearly.
> 
> If convert a guest to glance on v2v conversion server which is not
> conversion appliance on openstack, there is no need to set environment
> variable "export LIBGUESTFS_BACKEND=direct" during conversion
> 
> But if convert a guest to glance by v2v conversion server which is
> conversion appliance on openstack, need to set environment variable "export
> LIBGUESTFS_BACKEND=direct" during conversion
> 
> If convert a guest to openstack by v2v conversion server which is conversion
> appliance on openstack, need to set environment variable "export
> LIBGUESTFS_BACKEND=direct" during conversion whatever
> verify-server-certificate sets

Any time you have to set LIBGUESTFS_BACKEND=direct to make a conversion succeed,
it's a bug.  (We already have a few of these bugs so try not duplicate ones we
might already have!)

Comment 15 mxie@redhat.com 2019-04-10 05:49:37 UTC
> > If convert a guest to glance on v2v conversion server which is not
> > conversion appliance on openstack, there is no need to set environment
> > variable "export LIBGUESTFS_BACKEND=direct" during conversion
> > 
> > But if convert a guest to glance by v2v conversion server which is
> > conversion appliance on openstack, need to set environment variable "export
> > LIBGUESTFS_BACKEND=direct" during conversion
> > 
> > If convert a guest to openstack by v2v conversion server which is conversion
> > appliance on openstack, need to set environment variable "export
> > LIBGUESTFS_BACKEND=direct" during conversion whatever
> > verify-server-certificate sets

> Any time you have to set LIBGUESTFS_BACKEND=direct to make a conversion
> succeed,
> it's a bug.  (We already have a few of these bugs so try not duplicate ones
> we
> might already have!)

I think the problem is duplicated with bug1632231 due to below reasons

1.If convert a guest to glance/openstack on v2v conversion appliance of openstack without vddk, there is no need to set environment variable "export
LIBGUESTFS_BACKEND=direct" during conversion whatever

2.If disable selinux on v2v conversion appliance of openstack to convert a guest to glance/openstack, also don't need to set environment variable "export
LIBGUESTFS_BACKEND=direct" during conversion whatever

Comment 16 Richard W.M. Jones 2019-04-10 08:52:37 UTC
I don't think so.  Just because the error message is superficially the same doesn't
mean it's the same bug.  We will need a new bug filed, and both the full debug log
from virt-v2v and the SELinux audit messages.

Comment 17 mxie@redhat.com 2019-04-10 11:33:10 UTC
(In reply to Richard W.M. Jones from comment #16)
> I don't think so.  Just because the error message is superficially the same
> doesn't
> mean it's the same bug.  We will need a new bug filed, and both the full
> debug log
> from virt-v2v and the SELinux audit messages.

Thanks,filed bug1698437 to track this problem

Comment 18 mxie@redhat.com 2019-04-12 10:59:34 UTC
Verify the bug with builds:
virt-v2v-1.40.2-2.el7.x86_64
libguestfs-1.40.2-2.el7.x86_64
libguestfs-winsupport-7.2-3.el7.x86_64
libvirt-4.5.0-12.el7.x86_64
qemu-kvm-rhev-2.12.0-26.el7.x86_64
nbdkit-1.8.0-1.el7.x86_64
virtio-win-1.9.7-0.el7.noarch


Steps:
1.Check option -oo verify-server-certificate=false/true in virt-v2v man page
#man virt-v2v
....
       -oo verify-server-certificate
       -oo verify-server-certificate="true|false"
           For -o openstack (virt-v2v-output-openstack(1)) only, this can be used to disable SSL certification
           validation when connecting to OpenStack by specifying -oo verify-server-certificate=false.

#man virt-v2v-output-openstack
....
OpenStack: Ignore server certificate
       Using -oo verify-server-certificate=false you can tell the openstack client to
       ignore the server certificate when connecting to the OpenStack API endpoints.
       This has the same effect as passing the --insecure option to the "openstack"
       command.
....

2.Prepare a conversion appliance which have installed python2-openstackclient and virt-v2v on openstack environment

# openstack server list
+--------------------------------------+-------------------------------+--------+-----------------------+-----------------------+-----------+
| ID                                   | Name                          | Status | Networks              | Image                 | Flavor    |
+--------------------------------------+-------------------------------+--------+-----------------------+-----------------------+-----------+
| ff074bf3-51ed-4897-9a81-2ba97a69d81e | rhel7.6-v2v-conversion-server | ACTIVE | public01=10.73.224.5  | esx6.7-rhel7.6-x86_64 | m1.medium |
+--------------------------------------+-------------------------------+--------+-----------------------+-----------------------+-----------+

3.Copy keystone_admin from openstack root directory to v2v conversion appliance, then source keystone_admin to authenticate with openstack
#source keystone_admin


4.Convert a guest from Xen to openstack with option -oo verify-server-certificate=false
4.1 # virt-v2v -ic xen+ssh://root@10.73.3.21 xen-hvm-rhel7.6-x86_64 -o openstack -oo server-id=rhel7.6-v2v-conversion-server -oo verify-server-certificate=false
# virt-v2v -ic xen+ssh://root@10.73.3.21 xen-hvm-rhel7.6-x86_64 -o openstack -oo server-id=rhel7.6-v2v-conversion-server -oo verify-server-certificate=false
[   3.2] Opening the source -i libvirt -ic xen+ssh://root@10.73.3.21 xen-hvm-rhel7.6-x86_64
[   3.9] Creating an overlay to protect the source from being modified
[   5.0] Opening the overlay
[  60.8] Inspecting the overlay
[ 144.9] Checking for sufficient free disk space in the guest
[ 144.9] Estimating space required on target for each disk
[ 144.9] Converting Red Hat Enterprise Linux Server 7.6 (Maipo) to run on KVM
virt-v2v: warning: guest tools directory ‘linux/el7’ is missing from 
the virtio-win directory or ISO.

Guest tools are only provided in the RHV Guest Tools ISO, so this can 
happen if you are using the version of virtio-win which contains just the 
virtio drivers.  In this case only virtio drivers can be installed in the 
guest, and installation of Guest Tools will be skipped.
virt-v2v: This guest has virtio drivers installed.
[2552.7] Mapping filesystem data to avoid copying unused and blank areas
[2573.3] Closing the overlay
[2576.1] Assigning disks to buses
[2576.1] Checking if the guest needs BIOS or UEFI to boot
[2576.3] Initializing the target -o openstack
Failed to set volume read-only access mode flag: Invalid volume: Volume 3f8f6672-9a1f-4f2b-b4a3-a909e3e46c44 status must be available to update readonly flag, but current status is: creating. (HTTP 400) (Request-ID: req-0868257a-246e-46c6-9f78-3a5212d7f314)
[2599.9] Copying disk 1/1 to /dev/disk/by-id/virtio-3f8f6672-9a1f-4f2b-b (raw)
    (100.00/100%)
[3191.7] Creating output metadata
[3206.5] Finishing off


4.2 Launch the volume as instance on openstack webpage, Check points of guest are passed


5.Convert a windows guest from ova to openstack with option -oo verify-server-certificate=true

5.1# virt-v2v -i ova esx6.0-win2012r2-x86_64.ova -o openstack -oo server-id=rhel7.6-v2v-conversion-server -oo verify-server-certificate=true
[   2.0] Opening the source -i ova esx6.0-win2012r2-x86_64.ova
virt-v2v: warning: making OVA directory public readable to work around 
libvirt bug https://bugzilla.redhat.com/1045069
[  86.9] Creating an overlay to protect the source from being modified
[  87.8] Opening the overlay
[ 145.6] Inspecting the overlay
[ 186.4] Checking for sufficient free disk space in the guest
[ 186.5] Estimating space required on target for each disk
[ 186.5] Converting Windows Server 2012 R2 Standard to run on KVM
virt-v2v: warning: /usr/share/virt-tools/pnp_wait.exe is missing.  
Firstboot scripts may conflict with PnP.
virt-v2v: warning: there is no QXL driver for this version of Windows (6.3 
x86_64).  virt-v2v looks for this driver in 
/usr/share/virtio-win/virtio-win.iso

The guest will be configured to use a basic VGA display driver.
virt-v2v: This guest has virtio drivers installed.
[ 361.6] Mapping filesystem data to avoid copying unused and blank areas
[ 381.8] Closing the overlay
[ 384.5] Assigning disks to buses
[ 384.5] Checking if the guest needs BIOS or UEFI to boot
[ 384.5] Initializing the target -o openstack
Failed to set volume read-only access mode flag: Invalid volume: Volume 26d4d30e-2e08-46a4-b46f-a3bb8d0cb60a status must be available to update readonly flag, but current status is: creating. (HTTP 400) (Request-ID: req-2db9b77c-8cd5-497d-8c5f-219e2ab00284)
[ 418.7] Copying disk 1/1 to /dev/disk/by-id/virtio-26d4d30e-2e08-46a4-b (raw)
    (100.00/100%)
[ 810.1] Creating output metadata
[ 828.6] Finishing off

5.2 Launch the volume as instance on openstack webpage, Check points of guest are passed


6.Convert a guest from VMware via vmx to openstack with option -oo verify-server-certificate without value
#  virt-v2v -i vmx -it ssh ssh://root@10.73.75.219/vmfs/volumes/5aefd41e-1d448cf8-0b1f-001018d0c8e0/esx6.5-ubuntu18.04-x86_64-bug1481930/esx6.5-ubuntu18.04-x86_64-bug1481930.vmx -o openstack -oo server-id=rhel7.6-v2v-conversion-server -oo verify-server-certificate
[   1.7] Opening the source -i vmx ssh://root@10.73.75.219/vmfs/volumes/5aefd41e-1d448cf8-0b1f-001018d0c8e0/esx6.5-ubuntu18.04-x86_64-bug1481930/esx6.5-ubuntu18.04-x86_64-bug1481930.vmx
[   2.3] Creating an overlay to protect the source from being modified
[   2.8] Opening the overlay
[  55.1] Inspecting the overlay
[  82.2] Checking for sufficient free disk space in the guest
[  82.2] Estimating space required on target for each disk
[  82.2] Converting Ubuntu 18.04.1 LTS to run on KVM
virt-v2v: warning: could not determine a way to update the configuration of 
Grub2
virt-v2v: warning: don't know how to install guest tools on ubuntu-18
virt-v2v: This guest has virtio drivers installed.
[ 956.3] Mapping filesystem data to avoid copying unused and blank areas
[ 970.8] Closing the overlay
[ 972.4] Assigning disks to buses
[ 972.4] Checking if the guest needs BIOS or UEFI to boot
[ 972.4] Initializing the target -o openstack
Failed to set volume read-only access mode flag: Invalid volume: Volume 37b3bb36-7abf-48fb-842e-94fc6557be3b status must be available to update readonly flag, but current status is: creating. (HTTP 400) (Request-ID: req-d6a2e1df-ae63-42d8-93c1-6e764790adf2)
[1000.6] Copying disk 1/1 to /dev/disk/by-id/virtio-37b3bb36-7abf-48fb-8 (raw)
    (100.00/100%)
[1701.6] Creating output metadata
[1717.5] Finishing off


6.2 Launch the volume as instance on openstack webpage, Check points of guest are passed


7.Convert a guest s from VMware to openstack with option -oo verify-server-certificate with wrong value
# virt-v2v -ic vpx://root@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io  vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA -n default esx6.7-win2016-x86_64 --password-file /tmp/passwd -o openstack -oo server-id=rhel7.6-v2v-conversion-server -oo verify-server-certificate=wrong

virt-v2v: error: internal error: invalid argument: bool_of_string

If reporting bugs, run virt-v2v with debugging enabled and include the 
complete output:

  virt-v2v -v -x [...]

Result:
   virt-v2v can convert guest to openstack on conversion appliance with option verify-server-certificate correctly, so move the bug from ON_QA to VERIFIED

Comment 20 errata-xmlrpc 2019-08-06 12:44:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2096


Note You need to log in before you can comment on or make changes to this bug.