Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1651452 - After Fedora 29 upgrade and using kernel 4.19.2-300, F28 background shows and some applications don't work
Summary: After Fedora 29 upgrade and using kernel 4.19.2-300, F28 background shows and...
Keywords:
Status: CLOSED DUPLICATE of bug 1650224
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-20 06:55 UTC by Christopher Archer
Modified: 2018-11-26 19:52 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-26 19:52:57 UTC
Type: Bug


Attachments (Terms of Use)

Description Christopher Archer 2018-11-20 06:55:32 UTC
Description of problem:

Followed command-line instructions for upgrading from F28 to F29 as per https://fedoramagazine.org/upgrading-fedora-28-fedora-29/
After upgrade, logged in and noticed the background was still one from Fedora 28 (jellyfish). I also found I could not launch applications like Firefox, Thunderbird, Waterfox, Terminology and TeamViewer nor could I change the background, although I could launch VMware Player, AnyDesk and Remmina.

However, if I select the old F28 kernel (4.18.18-200.fc28.x86_64) at the boot menu all works fine. 

The "About" dialog shows Fedora 29. However, the fact that the boot menu shows and the background is still the F28 one suggests the upgrade was somehow 'partial'.

I don't know if this matters, but my boot drive is encrypted and continues to accept its password fine and perform properly.


Version-Release number of selected component (if applicable):
29

How reproducible:

Always if I boot using the kernel from the F29 upgrade 

Steps to Reproduce:
1. Perform command-line upgrade as per wiki
2. Boot into latest kernel (4.19.2-300.fc29.x86_64)
3.

Actual results:
Can't use some applications - they just appear to hang

Expected results:
All should work

Additional info:

I updated several virtual machines, and another machine at home with absolutely no problems.

I don't even know what to submit in terms of debug information to make sense of what happened or is happening.

Comment 1 Christopher Archer 2018-11-20 06:57:24 UTC
I'm also using the NVidia driver. Don't know if that might be a factor.

Comment 2 Daniel Mach 2018-11-26 12:47:49 UTC
Moving to the kernel component.
The upgrade has passed, we believe the problem is not in the DNF stack.

Comment 3 Jeremy Cline 2018-11-26 19:52:57 UTC
Hi Christopher,

There's a known issue with NVidia drivers and 4.19. A fix should be available in v4.19.5, which I expect will be available around Wednesday.

*** This bug has been marked as a duplicate of bug 1650224 ***


Note You need to log in before you can comment on or make changes to this bug.