Bug 1651469 - dnf cannot install the best update candidate for package libreoffice-core due libreoffice-gtk2 require old version
Summary: dnf cannot install the best update candidate for package libreoffice-core due...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-20 07:41 UTC by Mikhail
Modified: 2018-11-20 21:02 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-11-20 21:02:53 UTC


Attachments (Terms of Use)

Description Mikhail 2018-11-20 07:41:13 UTC
Description of problem:

# dnf update
Adobe Systems Incorporated                      2.5 kB/s | 2.9 kB     00:01
Fedora - Modular Rawhide - Developmental packag  10 kB/s |  19 kB     00:01
Fedora - Modular Rawhide - Developmental packag 381 kB/s | 1.8 MB     00:04
Fedora - Rawhide - Developmental packages for t 9.0 kB/s |  19 kB     00:02
Fedora - Rawhide - Debug                         10 kB/s |  19 kB     00:01
google-chrome-unstable                          1.2 kB/s | 1.3 kB     00:01
local repo                                      400 kB/s | 3.0 kB     00:00
Opera packages                                  2.3 kB/s | 2.9 kB     00:01
RPM Fusion for Fedora Rawhide - Free            6.3 kB/s |  10 kB     00:01
RPM Fusion for Fedora Rawhide - Nonfree         8.1 kB/s |  10 kB     00:01
Visual Studio Code                              2.3 kB/s | 2.9 kB     00:01
Dependencies resolved.

 Problem 1: cannot install both gnome-shell-extension-common-3.31.2-1.fc30.noarch and gnome-shell-extension-common-3.30.1-1.fc30.noarch
  - package gnome-shell-extension-alternate-tab-3.30.1-1.fc30.noarch requires gnome-shell-extension-common = 3.30.1-1.fc30, but none of the providers can be installed
  - cannot install the best update candidate for package gnome-shell-extension-common-3.30.1-1.fc30.noarch
  - problem with installed package gnome-shell-extension-alternate-tab-3.30.1-1.fc30.noarch
 Problem 2: cannot install both libreoffice-core-1:6.1.2.1-6.fc30.x86_64 and libreoffice-core-1:6.1.2.1-3.fc30.x86_64
  - package libreoffice-gtk2-1:6.1.2.1-3.fc30.x86_64 requires libreoffice-core(x86-64) = 1:6.1.2.1-3.fc30, but none of the providers can be installed
  - cannot install the best update candidate for package libreoffice-core-1:6.1.2.1-3.fc30.x86_64
  - problem with installed package libreoffice-gtk2-1:6.1.2.1-3.fc30.x86_64

Comment 1 Caolan McNamara 2018-11-20 08:52:27 UTC
looks like I got the wrong version for the Obsoletes


Note You need to log in before you can comment on or make changes to this bug.