Bug 165147 - Media check fails way too often
Media check fails way too often
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
n/a
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-04 13:44 EDT by Craig
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-08 17:57:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Craig 2005-08-04 13:44:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040316

Description of problem:
Starting with FC3 and with FC4, I have extreme difficulty getting burned CDs to work. If I mount the CDs they look OK, when I boot off them it seems to go OK, but then they fail the media check. If I ignore the media check and install anyway, it will abort sometime during RPM installation. Youd think this was a hardware issue with my system, but I've tried burning CDs using 2 different CD burners and one DVD burner, using 3 different computers. I've tried redownloading the iso images, doesn't help. Burning anything other than the Fedora CDs works fine. Happens nearly all the time. Only way I was able to get FC4 installed was using the DVD image.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download iso images
2. cdrecord -v -eject FC-whatever.iso
3. Boot from install CD
4. Anaconda's media check
  

Actual Results:  CDs reported as failing media check

Expected Results:  CDs should pass so I can install the friggin thing

Additional info:

This never happened with RedHat through RH9, nor with FC2. FC3 and FC4 I can't use CD isos, though a DVD iso usually works... but not all my computers can boot off DVD-ROM so I can't upgrade those machines. If this continues to be a problem, I'm going to have to abandon RedHat which I've been using for almost 10 years.
Comment 1 Andre Robatino 2005-08-05 10:26:12 EDT
  This has affected me since the first version which included the mediacheck,
which was back around 7.3.  The bug got ported from the 2.4 to the 2.6 kernel. 
I have 2 machines and it only affects one of them.  I am able to check the discs
using dd and sha1sum on a Solaris machine, but the same trick doesn't work for
me on Linux.  It also causes failure (claim of corrupted package) in the middle
of an install.  What I do now is to run the install using ide=nodma, which
prevents the failure, and then remove it from grub.conf (where it's
automatically included) afterwards.  If I run mediacheck itself using ide=nodma,
it either completes successfully with "passed" or hangs shortly before or after
reaching the end of the disc.  If it hangs on one or more discs, I just go ahead
and install, and it works.
Comment 2 Jeremy Katz 2005-08-08 17:57:05 EDT
Unfortunately, CD and CD writer reliability is beginning to mirror that of
floppies.  What software you use to write the cds seems to make a huge
difference.  Also, I'd suggest burning at a slower speed than what the
media/drive claim as their "maximum" as you'll get far better results burning at
the slower speeds.

Note You need to log in before you can comment on or make changes to this bug.