Bug 1651473 - Screen freeze while adding an automate domain with an invalid name
Summary: Screen freeze while adding an automate domain with an invalid name
Keywords:
Status: CLOSED DUPLICATE of bug 1650071
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.10.0
Assignee: Harpreet Kataria
QA Contact: Parthvi Vala
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-20 07:57 UTC by Parthvi Vala
Modified: 2018-11-28 15:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-27 18:35:00 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
Bug Demo (230.91 KB, application/octet-stream)
2018-11-20 07:57 UTC, Parthvi Vala
no flags Details

Description Parthvi Vala 2018-11-20 07:57:54 UTC
Created attachment 1507361 [details]
Bug Demo

Description of problem:
Screen freezes with an error message on `Add a new Automate Domain` page when an invalid name is entered in the `Name` field.

Version-Release number of selected component (if applicable):
5.10.0.24

How reproducible:
Always

Steps to Reproduce:
1. Navigate to `Automation` > `Automate` > `Explorer`
2. Click on `Configuration` and select `Add a new domain`
3. Add some invalid name such as `domain_!`
4. Click on `Add`

Actual results:
Error displayed on the screen along with a spinner spinning continuously, freezing the screen and not allowing the user to change name or any other fields.

Expected results:
Error must be displayed, but the user must be allowed to change the fields, without any screen freeze.

Additional info:
Works fine on 5.9 builds, but not on 5.10 builds.

Comment 4 Harpreet Kataria 2018-11-27 18:35:00 UTC

*** This bug has been marked as a duplicate of bug 1650071 ***


Note You need to log in before you can comment on or make changes to this bug.