Bug 165149 - can not request from .de domain
Summary: can not request from .de domain
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: jwhois   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-04 17:56 UTC by Thilo Pfennig
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 3.2.3-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-05 13:40:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thilo Pfennig 2005-08-04 17:56:16 UTC
Description of problem:
I do not get results with defaults when querying a .DE -domain (Germany)


Version-Release number of selected component (if applicable):

jwhois-3.2.2-14


How reproducible:

always

Steps to Reproduce:
1. whois web.de
  
Actual results:

[Querying http://www.denic.de/en/whois/data.jsp]

Expected results:

listing of domain

Additional info:

when quering with whois web.de -h whois.thur.de I get correct results.

Comment 1 Thilo Pfennig 2005-08-04 18:02:05 UTC
I have the solution:


jwhois seems to depend on an installed package "lynx" ( I saw a message about
browser not found via gnome-networktools). I seems to be unable to fetch the
information with another text browser or by itself.

Comment 2 Miloslav Trmač 2005-08-05 13:40:53 UTC
Comment #1 is correct: a web browser is necessary for http queries.  The default
configuration uses lynx, but jwhois can't depend on lynx (#161282) because it
can use other browsers (at least w3m) if so configured.

There is a separate bug in jwhois which can cause jwhois to exit after writing the
[Querying ...] line without reporting that executing the browser failed.  This bug
will be fixed in rawhide jwhois-3.2.3-2.

Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.