Bug 1651542 - test_pod_service_curl fails with multiprocessing.TimeoutError
Summary: test_pod_service_curl fails with multiprocessing.TimeoutError
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-kuryr-tests-tempest
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 15.0 (Stein)
Assignee: Yossi Boaron
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-20 10:06 UTC by Itzik Brown
Modified: 2019-11-04 12:21 UTC (History)
4 users (show)

Fixed In Version: python-kuryr-tests-tempest-0.4.1-0.20190401185124.0d51e99.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:19:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 618982 None master: MERGED kuryr-tempest-plugin: Add timeout to calls for ws_client.py functions (I9fdeaaeee3dad432135cf864a2d34198f18af705) 2019-03-07 20:18:00 UTC
Red Hat Product Errata RHEA-2019:2811 None None None 2019-09-21 11:19:49 UTC

Description Itzik Brown 2018-11-20 10:06:44 UTC
Description of problem:
Running the test kuryr_tempest_plugin.tests.scenario.test_service.TestServiceScenario.test_pod_service_curl fails with the following trace:
Traceback (most recent call last):
  File "/home/centos/tempest-upstream/kuryr-tempest-plugin/kuryr_tempest_plugin/tests/scenario/test_service.py", line 51, in test_pod_service_curl
    pod_name)
  File "/home/centos/tempest-upstream/kuryr-tempest-plugin/kuryr_tempest_plugin/tests/scenario/base.py", line 622, in assert_backend_amount_from_pod
    fn_timeout=request_timeout)
  File "/home/centos/tempest-upstream/kuryr-tempest-plugin/kuryr_tempest_plugin/tests/scenario/base.py", line 628, in _run_threaded_and_assert
    resps = [result.get(timeout=fn_timeout) for result in results]
  File "/usr/lib64/python2.7/multiprocessing/pool.py", line 550, in get
    raise TimeoutError
multiprocessing.TimeoutError


Version-Release number of selected component (if applicable):
OCP 3.11
OSP14
kuryr-tempest-plugin fron git/master
How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 11 Itzik Brown 2019-09-10 09:09:46 UTC
Verified 
python3-kuryr-tests-tempest-0.4.1-0.20190401185124.0d51e99.el8ost.noarch

Comment 13 errata-xmlrpc 2019-09-21 11:19:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.