Bug 1651622 - [container doc] - iscsi configuration section needs change
Summary: [container doc] - iscsi configuration section needs change
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation
Version: 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 3.2
Assignee: Aron Gunn
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-20 12:26 UTC by ymane
Modified: 2019-08-26 06:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-26 06:55:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description ymane 2018-11-20 12:26:10 UTC
Description of problem:
Container Guide:https://access.qa.redhat.com/documentation/en-us/red_hat_ceph_storage/3/html-single/container_guide/#installing-the-ceph-iscsi-gateway-in-a-container-container
Chapter 1
section 6
"Important" section mentioning gateway_ip_list is not supported for container based deployment,but it is failing with the error mentioned below.

Just add note that gateway_ip_list should be mentioned in iscsigws.yml for copying the packages required for iscsi.

TASK [ceph-iscsi-gw : make sure gateway_ip_list is configured] ****************************************************************************************************************************************************
Monday 19 November 2018  11:19:21 +0000 (0:00:00.315)       0:09:01.571 ******* 
fatal: [magna066]: FAILED! => {"changed": false, "msg": "you must set a list of IPs (comma separated) for gateway_ip_list"}
fatal: [magna087]: FAILED! => {"changed": false, "msg": "you must set a list of IPs (comma separated) for gateway_ip_list"}


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Playbook should work fine without any errors


Additional info:


Note You need to log in before you can comment on or make changes to this bug.