Bug 1651643 - Unable to render Kickstart default template with IdM integration - realm type specified is FreeIPA
Summary: Unable to render Kickstart default template with IdM integration - realm type...
Keywords:
Status: CLOSED DUPLICATE of bug 1646747
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning Templates
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-20 13:19 UTC by Gianfranco Sigrisi
Modified: 2018-11-20 13:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-20 13:36:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gianfranco Sigrisi 2018-11-20 13:19:32 UTC
Description of problem:

After creating the REALM in Satellite I was not able to render properly the provisioning template Kickstart Default.

<% if host_enc['parameters']['realm'] && @host.realm && @host.realm.realm_type == 'FreeIPA' -%>
<%= snippet 'freeipa_register' %>
<% end -%>


hammer realm info --id 1 reports:

REALM type: Red Hat Identity Management


Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

The issue is solved by modifying the template in this way:
<% if host_enc['parameters']['realm'] && @host.realm && @host.realm.realm_type == 'Red Hat Identity Management' -%>
<%= snippet 'freeipa_register' %>
<% end -%>

Comment 1 Evgeni Golov 2018-11-20 13:36:38 UTC

*** This bug has been marked as a duplicate of bug 1646747 ***


Note You need to log in before you can comment on or make changes to this bug.