Bug 1651644 - RHEL 8 beta + flatpak
Summary: RHEL 8 beta + flatpak
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: flatpak
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: David King
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-20 13:20 UTC by ignusius
Modified: 2020-02-10 08:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-07 14:46:52 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Error fatpak (456.84 KB, image/png)
2018-11-20 13:20 UTC, ignusius
no flags Details

Description ignusius 2018-11-20 13:20:10 UTC
Created attachment 1507413 [details]
Error fatpak

Description of problem:
When install some flatpak package from lathub.org by GNOME Software, then show error, see attachment.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 ignusius 2018-11-21 05:56:49 UTC
fix  "lathub.org" -> "flathub.org"

Comment 5 Tomas Pelka 2018-11-21 07:37:13 UTC
I'm guessing flathub.org is the one who should be blamed. Seems there service is a bit unstable. We can see that too time to time. Please try again.

Comment 6 ignusius 2018-11-21 07:49:41 UTC
(In reply to Tomas Pelka from comment #5)
> I'm guessing flathub.org is the one who should be blamed. Seems there
> service is a bit unstable. We can see that too time to time. Please try
> again.

I'm try install flatpak by CLI in RHEL 7.6/8.0 Beta, and all work right! It problem only RHEL, because in Fedora 28/29 all work right! Problem in GNOME Software Center!

Comment 7 Martin Krajnak 2018-11-21 11:05:45 UTC
(In reply to ignusius from comment #6)
> (In reply to Tomas Pelka from comment #5)
> > I'm guessing flathub.org is the one who should be blamed. Seems there
> > service is a bit unstable. We can see that too time to time. Please try
> > again.
> 
> I'm try install flatpak by CLI in RHEL 7.6/8.0 Beta, and all work right! It
> problem only RHEL, because in Fedora 28/29 all work right! Problem in GNOME
> Software Center!

Hello, it's very strange, I am not able to reproduce the issue. When you are trying to install some other flatpaks, any of skype, spotify or inkscape, is the result same for you on RHEL8 machine ?

If true, can you please provide us with information about package versions you are using by opening the terminal, executing the following commands:

1.rpm -q gnome-software
2.rpm -q flatpak

Additionally, it would help if you can provide additional log by running:

1.Make sure that your Sofware is not performing any installation or update
2.Open your terminal and execute
3.pkill gnome-software
4.gnome-software --verbose &> logfile.txt
5.Try to install again
6.Go back to your terminal and press ctr+c to close the process
7.Upload the logfile.txt from your home folder here

Thank you

Comment 8 ignusius 2018-11-21 17:18:43 UTC
(In reply to Martin Krajnak from comment #7)
> (In reply to ignusius from comment #6)
> > (In reply to Tomas Pelka from comment #5)
> > > I'm guessing flathub.org is the one who should be blamed. Seems there
> > > service is a bit unstable. We can see that too time to time. Please try
> > > again.
> > 
> > I'm try install flatpak by CLI in RHEL 7.6/8.0 Beta, and all work right! It
> > problem only RHEL, because in Fedora 28/29 all work right! Problem in GNOME
> > Software Center!
> 
> Hello, it's very strange, I am not able to reproduce the issue. When you are
> trying to install some other flatpaks, any of skype, spotify or inkscape, is
> the result same for you on RHEL8 machine ?
> 
> If true, can you please provide us with information about package versions
> you are using by opening the terminal, executing the following commands:
> 
> 1.rpm -q gnome-software
> 2.rpm -q flatpak
> 
> Additionally, it would help if you can provide additional log by running:
> 
> 1.Make sure that your Sofware is not performing any installation or update
> 2.Open your terminal and execute
> 3.pkill gnome-software
> 4.gnome-software --verbose &> logfile.txt
> 5.Try to install again
> 6.Go back to your terminal and press ctr+c to close the process
> 7.Upload the logfile.txt from your home folder here
> 
> Thank you

Only later, because my RHEL 8 in Virtual Box is broken. I reinstall it and reply here!

Comment 9 ignusius 2018-11-22 20:53:33 UTC
(In reply to Martin Krajnak from comment #7)
> (In reply to ignusius from comment #6)
> > (In reply to Tomas Pelka from comment #5)
> > > I'm guessing flathub.org is the one who should be blamed. Seems there
> > > service is a bit unstable. We can see that too time to time. Please try
> > > again.
> > 
> > I'm try install flatpak by CLI in RHEL 7.6/8.0 Beta, and all work right! It
> > problem only RHEL, because in Fedora 28/29 all work right! Problem in GNOME
> > Software Center!
> 
> Hello, it's very strange, I am not able to reproduce the issue. When you are
> trying to install some other flatpaks, any of skype, spotify or inkscape, is
> the result same for you on RHEL8 machine ?
> 
> If true, can you please provide us with information about package versions
> you are using by opening the terminal, executing the following commands:
> 
> 1.rpm -q gnome-software
> 2.rpm -q flatpak
> 
> Additionally, it would help if you can provide additional log by running:
> 
> 1.Make sure that your Sofware is not performing any installation or update
> 2.Open your terminal and execute
> 3.pkill gnome-software
> 4.gnome-software --verbose &> logfile.txt
> 5.Try to install again
> 6.Go back to your terminal and press ctr+c to close the process
> 7.Upload the logfile.txt from your home folder here
> 
> Thank you

I reinstalled RHEL 8 and error doesn't show.

Comment 10 Tomas Popela 2020-02-07 14:46:52 UTC
Martine, this should now work, no? If so, please close it.

Comment 11 Martin Krajnak 2020-02-07 21:26:17 UTC
I believe this was fixed on server side: https://github.com/flathub/flathub/issues/845

Comment 12 Tomas Popela 2020-02-10 08:12:19 UTC
Fixing the state of the bug.


Note You need to log in before you can comment on or make changes to this bug.