Bug 1651691 - Changing kdump location to"Use the setting in /etc/kdump.conf" failed with cockpit UI.
Summary: Changing kdump location to"Use the setting in /etc/kdump.conf" failed with co...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: cockpit
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 8.0
Assignee: Martin Pitt
QA Contact: Jan Ščotka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-20 15:20 UTC by Martin Pitt
Modified: 2019-06-11 19:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1536327
Environment:
Last Closed: 2019-05-23 11:54:21 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Pitt 2018-11-20 15:20:02 UTC
+++ This bug was initially created as a clone of Bug #1536327 +++

Description of problem:
Kdump can be located in Local/nfs/ssh with cockpit WebUI, local file-system is the default. If a user wants to use NFS/SSH for kdump, the location should be changed to "Use the setting in /etc/kdump.conf" with cockpit UI. But now apply changing failed, location still points to "locally in /var/crash", and vmcore files are still created in /etc/crash of localhost.

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.2-20180115.0
cockpit-ws-157-1.el7.x86_64
cockpit-dashboard-157-1.el7.x86_64
cockpit-bridge-157-1.el7.x86_64
cockpit-157-1.el7.x86_64
cockpit-storaged-157-1.el7.noarch
cockpit-system-157-1.el7.noarch
cockpit-ovirt-dashboard-0.11.4-0.1.el7ev.noarch
kernel-3.10.0-693.11.6.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Clean install redhat-virtualization-host-4.2-20180115.0 with ks
2. Login to cockpit with root account
3. Go to Kernel Dump, open Crash dump location window
4. Apply the location to "Use the setting in /etc/kdump.conf" after setting nfs/ssh kdump in /etc/kdump.conf file
5. Check the setting in cockpit UI
6. Click "Test Configuration", then "Crash system"

Actual results:
After step 5, changing kdump location to"Use the setting in /etc/kdump.conf" failed, location still points to "locally in /var/crash".
After step 6, vmcore files are created in /etc/crash of localhost.

Expected results:
After step 5, the location should point to nfs/ssh address.
After step 6, vmcore files should be created in remote nfs/ssh server.


Additional info:

--- Additional comment from Wei Wang on 2018-01-19 02:20 EST ---



--- Additional comment from Red Hat Bugzilla Rules Engine on 2018-01-19 08:19:45 EST ---

Since this bug report was entered in Red Hat Bugzilla, the release flag has been set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Martin Pitt on 2018-10-17 03:59:22 EDT ---

Confirmed, this also affects RHEL 8.

--- Additional comment from Martin Pitt on 2018-10-17 04:10:29 EDT ---

What does work is to edit /etc/kdump.conf, disable "path" and enable "nfs", then the Cockpit display immediately changes to "Remote over NFS". Then it's also possible to change the NFS location in the Cockpit UI.

But this already fails again when enabling "ssh" or "ext4" in kdump.conf, then the UI immediately switches back to "locally in /var/crash".

Also, changing the path in kdump.conf to "path /var/crash2" or something else isn't properly reflected in the UI. This only works in the Cockpit → config file direction.

--- Additional comment from Martin Pitt on 2018-10-17 04:26:29 EDT ---

I created https://projects.engineering.redhat.com/browse/COCKPIT-289 to revamp the design of this.

--- Additional comment from Martin Pitt on 2018-11-20 09:22:16 EST ---

This got fixed in https://github.com/cockpit-project/cockpit/pull/10513


Note You need to log in before you can comment on or make changes to this bug.