Bug 1651699 - Taxonomies not handled properly with role for viewing host facts
Summary: Taxonomies not handled properly with role for viewing host facts
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Users & Roles
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Radovan Drazny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-20 15:42 UTC by Perry Gagne
Modified: 2020-08-05 09:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-15 20:30:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 30567 Normal New Taxonomies not handled properly with role for viewing host facts 2020-08-05 09:30:58 UTC
Red Hat Bugzilla 1569395 high CLOSED [Satellite 6] Adding search for lifecycle_environment or lifecycle_environment_id in role host fiter with permission vie... 2019-12-09 18:49:07 UTC
Red Hat Bugzilla 1646755 high CLOSED [Satellite 6] Adding search for lifecycle_environment or lifecycle_environment_id in role host fiter with permission vie... 2019-12-09 18:49:07 UTC

Internal Links: 1569395 1646755

Description Perry Gagne 2018-11-20 15:42:20 UTC
Description of problem:
While verifying bz 1646755 we discovered another issue if the role has taxonomy (Organization and Location) filters set. See bug 1646755, comment 4 for more info 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Created Lifecycle Environments DEV (id=2), QA (id=3)
2. Created Hosts qa1 , dev1 
3. Created role 'integrationsrole' role as described in https://access.redhat.com/articles/3359731
4. Added filter to view host rule "lifecycle_environment = DEV"
5. Set Organization and location for integrationsrole to the same as dev1
6. Created apiuser with integrationsrole.
7. curl -s -u 'apiuser:redhat' -k https://$SATELLITE/api/v2/hosts/$dev1_id/facts

Actual results: Returned result is empty:
{
  "total": 0,
  "subtotal": 0,
  "page": 1,
  "per_page": 20,
  "search": " host = 2",
  "sort": {
    "by": null,
    "order": null
  },
  "results": {}
}

Expected results:
The facts for the host are returned. 


Additional info: If you remove the Org and location from integrationsrole, you get the following result, which I think is correct but am not sure why all those values are null:
{
  "total": 0,
  "subtotal": 1,
  "page": 1,
  "per_page": 20,
  "search": " host = 2",
  "sort": {
    "by": null,
    "order": null
  },
  "results": {"dev1.lab.eng.rdu2.redhat.com":{"net::interface::eth0::ipv6_address":null,"net::interface::eth0::ipv6_netmask":null,"cpu":null,"network":null,"dmi::bios":null,"distribution":null,"virt":null,"net":null,"dmi::system":null,"lscpu":null,"dmi::processor":null,"dmi::chassis":null,"proc_cpuinfo::common":null,"proc_cpuinfo":null,"dmi::memory":null,"dmi":null,"net::interface::eth0":null,"net::interface":null,"proc_stat":null,"system":null}}

Comment 5 Bryan Kearney 2019-12-03 16:34:54 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 6 Bryan Kearney 2020-01-15 20:30:43 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.

Comment 7 Ondřej Ezr 2020-08-05 09:30:57 UTC
Created redmine issue https://projects.theforeman.org/issues/30567 from this bug


Note You need to log in before you can comment on or make changes to this bug.