Bug 1651749 - Trying to select a skin tone emoji crashes the application
Summary: Trying to select a skin tone emoji crashes the application
Keywords:
Status: CLOSED DUPLICATE of bug 1651999
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-20 16:48 UTC by Mike FABIAN
Modified: 2019-09-17 06:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-17 06:15:39 UTC


Attachments (Terms of Use)

Description Mike FABIAN 2018-11-20 16:48:05 UTC
When using gedit or nautilus or probably any other such Gnome application,
trying to insert a skin tone emoji makes the application crash.

- For example, open gedit.
- Click the right mouse button for the context menu.
- Select  "insert emoji"
- Scroll down to an emoji which should have skin tones, for example
  🧒 U+1F9D2 CHILD
- Long press with the left mouse button or click the right mouse 
  button on that emoji. 

-> The application crashes.

Comment 1 Mike FABIAN 2018-11-20 17:05:59 UTC
Backtrace from gedit:

[mfabian@Fedora-Workstation-netinst-x86_6 ~]$ gdb core.gedit 
gdb core.gedit 
GNU gdb (GDB) Fedora 8.2-3.fc29
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
[New LWP 10696]
[New LWP 10704]
[New LWP 10705]
[New LWP 10706]
[New LWP 10703]
Reading symbols from /usr/bin/gedit...Reading symbols from /usr/lib/debug/usr/bin/gedit-3.30.2-1.fc29.x86_64.debug...done.
done.

warning: Ignoring non-absolute filename: <linux-vdso.so.1>
Missing separate debuginfo for linux-vdso.so.1
Try: dnf --enablerepo='*debug*' install /usr/lib/debug/.build-id/07/867c9ca9183766866c4f743cb0946f730957bd

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments
Core was generated by `gedit'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007ff50ea0af03 in add_emoji (box=box@entry=0x5631c56fd8b0, 
    prepend=prepend@entry=0, item=item@entry=0x5631c57ffa10, modifier=modifier@entry=0, 
    chooser=chooser@entry=0x0) at gtkemojichooser.c:407
407	  if (pango_layout_get_unknown_glyphs_count (layout) > 0 ||
[Current thread is 1 (Thread 0x7ff50d24ea80 (LWP 10696))]
(gdb) bt
bt
#0  0x00007ff50ea0af03 in add_emoji (box=box@entry=0x5631c56fd8b0, 
    prepend=prepend@entry=0, item=item@entry=0x5631c57ffa10, modifier=modifier@entry=0, 
    chooser=chooser@entry=0x0) at gtkemojichooser.c:407
#1  0x00007ff50ea0c1fb in show_variations (child=<optimized out>, chooser=<optimized out>)
    at gtkemojichooser.c:305
#2  0x00007ff50d729ace in ffi_call_unix64 () at ../src/x86/unix64.S:76
#3  0x00007ff50d72948f in ffi_call (cif=cif@entry=0x7ffe83941c90, 
    fn=fn@entry=0x7ff50ea0c2c0 <long_pressed_cb>, rvalue=<optimized out>, 
    avalue=avalue@entry=0x7ffe83941ba0) at ../src/x86/ffi64.c:525
#4  0x00007ff50e1edc66 in g_cclosure_marshal_generic_va (closure=<optimized out>, 
    return_value=<optimized out>, instance=<optimized out>, args_list=<optimized out>, 
    marshal_data=<optimized out>, n_params=<optimized out>, param_types=<optimized out>)
    at gclosure.c:1610
#5  0x00007ff50e1ecef6 in _g_closure_invoke_va (closure=0x5631c5741630, return_value=0x0, 
    instance=0x5631c4e9d300, args=0x7ffe83941f40, n_params=2, param_types=0x5631c4dc3d10)
    at gclosure.c:873
#6  0x00007ff50e209381 in g_signal_emit_valist (instance=0x5631c4e9d300, 
    signal_id=<optimized out>, detail=0, var_args=var_args@entry=0x7ffe83941f40)
    at gsignal.c:3300
#7  0x00007ff50e209923 in g_signal_emit (instance=instance@entry=0x5631c4e9d300, 
    signal_id=<optimized out>, detail=detail@entry=0) at gsignal.c:3447
#8  0x00007ff50ea5981d in _gtk_gesture_long_press_timeout (user_data=0x5631c4e9d300)
    at gtkgesturelongpress.c:108
#9  0x00007ff50e788bac in gdk_threads_dispatch (data=data@entry=0x5631c4baa960)
    at gdk.c:755
#10 0x00007ff50e109d31 in g_timeout_dispatch (source=0x5631c5e95cb0, 
    callback=0x7ff50e788b80 <gdk_threads_dispatch>, user_data=0x5631c4baa960)
    at gmain.c:4667
#11 0x00007ff50e10926d in g_main_dispatch (context=0x5631c49c1b20) at gmain.c:3182
#12 g_main_context_dispatch (context=context@entry=0x5631c49c1b20) at gmain.c:3847
#13 0x00007ff50e109638 in g_main_context_iterate (context=context@entry=0x5631c49c1b20, 
    block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3920
#14 0x00007ff50e1096d0 in g_main_context_iteration (context=context@entry=0x5631c49c1b20, 
    may_block=may_block@entry=1) at gmain.c:3981
#15 0x00007ff50e453465 in g_application_run (application=0x5631c49b61e0, 
    argc=<optimized out>, argv=0x7ffe83942328) at gapplication.c:2470
#16 0x00005631c2fb230e in main (argc=1, argv=0x7ffe83942328) at gedit/gedit.c:146
(gdb)

Comment 2 Mike FABIAN 2018-11-21 11:49:32 UTC
I reported this manually because gnome-abrt didn’t work. But now 
I got it working again and reported:

https://bugzilla.redhat.com/show_bug.cgi?id=1651999

So one of these bugs should probably be closed as a duplicate of the other.

Comment 3 Mike FABIAN 2019-09-17 06:15:39 UTC

*** This bug has been marked as a duplicate of bug 1651999 ***


Note You need to log in before you can comment on or make changes to this bug.