Bug 1651775 - openvswitch fails rpm -V after a fresh install
Summary: openvswitch fails rpm -V after a fresh install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch
Version: 7.7
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: David Marchand
QA Contact: Jean-Tsung Hsiao
URL:
Whiteboard:
Depends On:
Blocks: 1659391
TreeView+ depends on / blocked
 
Reported: 2018-11-20 19:28 UTC by Flavio Leitner
Modified: 2019-03-06 10:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1659391 (view as bug list)
Environment:
Last Closed: 2019-03-06 10:56:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0466 None None None 2019-03-06 10:56:42 UTC

Description Flavio Leitner 2018-11-20 19:28:45 UTC
Description of problem:
After a fresh install, the rpm -V openvswitch report errors.


Version-Release number of selected component (if applicable):
# rpm -q openvswitch 
openvswitch-2.9.0-81.el7fdp.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Install openvswitch for the first time.
2. Start the service
3. run 'rpm -V openvswitch'

Actual results:
# rpm -V openvswitch
.....UG..  c /etc/openvswitch/system-id.conf


Expected results:
No output, all files are okay.

Additional info:
RPM is expecting the file to be owned by openvswitch.openvswitch:
# rpm -qlv openvswitch | grep system-id.conf
-rw-r--r-- 1 openvswiopenvswi 0 Nov 9 13:20 /etc/openvswitch/system-id.conf


But in this case it is owned by root.root:
# ls -la /etc/openvswitch/system-id.conf 
-rw-r--r--. 1 root root 37 Nov 20 13:46 /etc/openvswitch/system-id.conf


and the service runs as openvswitch user:
[root@localhost tmp]# ps -q `pidof ovs-vswitchd` -Ao user,group 
USER     GROUP
openvsw+ hugetlbfs
[root@localhost tmp]# ps -q `pidof ovsdb-server` -Ao user,group 
USER     GROUP
openvsw+ hugetlbfs


# id openvswitch 
uid=996(openvswitch) gid=993(openvswitch) groups=993(openvswitch),1000(hugetlbfs)

Comment 3 Jean-Tsung Hsiao 2019-02-20 20:18:01 UTC
[root@netqe30 ~]# rpm -q openvswitch
openvswitch-2.9.0-95.el7fdp.x86_64
[root@netqe30 ~]# rpm -V openvswitch
[root@netqe30 ~]# systemctl start openvswitch
[root@netqe30 ~]# rpm -V openvswitch
[root@netqe30 ~]# ovs-vsctl show
5040f63d-5d41-4a8f-961c-41c90a330810
    ovs_version: "2.9.0"

Comment 5 errata-xmlrpc 2019-03-06 10:56:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0466


Note You need to log in before you can comment on or make changes to this bug.