Bug 1651784 - apiservice pod's service has endpoint but `oc` gets no route to host [NEEDINFO]
Summary: apiservice pod's service has endpoint but `oc` gets no route to host
Keywords:
Status: CLOSED DUPLICATE of bug 1689690
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.11.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 3.11.z
Assignee: jtanenba
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-20 20:10 UTC by Justin Pierce
Modified: 2019-03-26 16:07 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-26 16:07:29 UTC
Target Upstream Version:
jtanenba: needinfo? (jupierce)


Attachments (Terms of Use)
Listings (2.19 KB, text/plain)
2018-11-20 20:10 UTC, Justin Pierce
no flags Details

Description Justin Pierce 2018-11-20 20:10:05 UTC
Created attachment 1507459 [details]
Listings

Description of problem:
During an upgrade from v3.11.16 to v3.11.44 encountered an error where it timed out waiting for /apis/metrics.k8s.io/v1beta1 to register. Upon investigation, it was determined that the pod backing this API service was running, it was was addressable via the pod IP, but was not addressable via the service IP.

See attached listings for details.


Version-Release number of selected component (if applicable):
v3.11.16

How reproducible:
Unknown

Comment 12 jtanenba 2019-02-15 20:57:56 UTC
Hi Justin,

Sorry this has been on the backburner but when/if this happens again could you give us some information
   could you get the sdn logs and output of iptables-save from the node running the curl and the serviceIP's and endpointIP's of the the endpoint being curled 


I am on PTO next week 2/18-2/22 but when I get back these logs should help debug the issue

Comment 13 Stephen Cuppett 2019-03-15 00:00:29 UTC
This has not been an issue in OpenShift Online Starter since 3.11.82.

Comment 14 Ben Bennett 2019-03-26 16:07:29 UTC

*** This bug has been marked as a duplicate of bug 1689690 ***


Note You need to log in before you can comment on or make changes to this bug.