Bug 1651831 - Failed to create silence
Summary: Failed to create silence
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Frederic Branczyk
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-21 00:55 UTC by Junqi Zhao
Modified: 2019-06-04 10:40 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
Failed to create silence (234.81 KB, image/png)
2018-11-21 00:55 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:59 UTC

Description Junqi Zhao 2018-11-21 00:55:03 UTC
Created attachment 1507476 [details]
Failed to create silence

Description of problem:
This bug is cloned from https://jira.coreos.com/browse/MON-468
File it again for QE team to track the monitoring issue.

Failed to create silence, two errors:

1. Fetch API cannot load https://alertmanager-main-openshift-monitoring.apps.1119-qbm.qe.rhcloud.com/api/v1/silences. Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://console.apps.1119-qbm.qe.rhcloud.com' is therefore not allowed access. The response had HTTP status code 403. If an opaque response serves your needs, set the request's mode to 'no-cors' to fetch the resource with CORS disabled.

 

2.Uncaught (in promise) TypeError: Cannot read property 'error' of undefined
    at main-chunk-7979f98df90ccd5d2d0c.min.js:1
    at <anonymous>
(anonymous) @ main-chunk-7979f98df90ccd5d2d0c.min.js:1
main-chunk-7979f98df90ccd5d2d0c.min.js:1 Fetch complete: GET "https://console.apps.1119-qbm.qe.rhcloud.com/api/alertmanager/api/v1/silences".
v @ main-chunk-7979f98df90ccd5d2d0c.min.js:1
g @ main-chunk-7979f98df90ccd5d2d0c.min.js:1
a @ main-chunk-7979f98df90ccd5d2d0c.min.js:1

It's the same error when create silence by clicking the "Silence Alert" cog memu from "Monitoring -> Alerts" page

Version-Release number of selected component (if applicable):
docker.io/grafana/grafana:5.2.4
docker.io/openshift/oauth-proxy:v1.1.0
docker.io/openshift/prometheus-alertmanager:v0.15.2
docker.io/openshift/prometheus-node-exporter:v0.16.0
docker.io/openshift/prometheus:v2.5.0
quay.io/coreos/configmap-reload:v0.0.1
quay.io/coreos/kube-rbac-proxy:v0.4.0
quay.io/coreos/kube-state-metrics:v1.4.0
quay.io/coreos/prom-label-proxy:v0.1.0
quay.io/coreos/prometheus-config-reloader:v0.25.0
quay.io/coreos/prometheus-operator:v0.25.0
quay.io/openshift/origin-cluster-monitoring-operator:v4.0
quay.io/openshift/origin-configmap-reload:v3.11
quay.io/openshift/origin-telemeter:v4.0

Browser: Chrome, version 58.0.3029.81 (64-bit)

How reproducible:
Always

Steps to Reproduce:
1. Login cluster console as cluster-admin, and click "Monitoring -> Silences", and then click "Create Silence" button in the page
2. Input value for the fields, then click "Create" button
3.

Actual results:
Failed to create silence

Expected results:
Be able to create silence

Additional info:

Comment 1 Junqi Zhao 2018-11-21 01:10:24 UTC
Blocks the create silence story testing

Comment 2 Junqi Zhao 2018-11-21 01:14:00 UTC
@Frederic, it seem Andy does not have bugzilla account now, will re-assign to him after his account is normal


Assignee: 	
anpicker@redhat.com did not match anything

Comment 3 Junqi Zhao 2018-11-23 06:43:46 UTC
move to VERIFIED, issue is fixed, could create silence now

Comment 6 errata-xmlrpc 2019-06-04 10:40:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.