Bug 1651843 - screen dump of window 10 guest shows blurred screen with qxl driver,this can't be reproduced without qxl driver
Summary: screen dump of window 10 guest shows blurred screen with qxl driver,this can'...
Keywords:
Status: CLOSED DUPLICATE of bug 1018668
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: qemu-kvm
Version: 8.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 8.0
Assignee: Gerd Hoffmann
QA Contact: Guo, Zhiyi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-21 02:39 UTC by liunana
Modified: 2019-05-22 05:35 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-05 10:23:09 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
blurred screen picture (2.25 MB, application/octet-stream)
2018-11-21 02:39 UTC, liunana
no flags Details

Description liunana 2018-11-21 02:39:35 UTC
Created attachment 1507479 [details]
blurred screen picture

Description of problem:
screen dump of window 10 guest shows blurred screen with qxl driver, this can't be reproduced without qxl driver


Version-Release number of selected component (if applicable):
(host)
# uname -r 
4.18.0-37.el8.x86_6

# rpm -qa | grep qemu
qemu-kvm-block-iscsi-debuginfo-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-guest-agent-debuginfo-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-img-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-kvm-block-iscsi-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-kvm-block-curl-debuginfo-3.0.0-1.el8+2055+38c90e40.x86_64
ipxe-roms-qemu-20170710-5.git0600d3ae.module+el8+2158+2adef74d.noarch
qemu-kvm-debuginfo-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-kvm-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-kvm-core-debuginfo-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-kvm-block-ssh-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-kvm-block-rbd-debuginfo-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-kvm-block-curl-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-img-debuginfo-3.0.0-1.el8+2055+38c90e40.x86_64
libvirt-daemon-driver-qemu-4.5.0-13.module+el8+2158+2adef74d.x86_64
qemu-kvm-debugsource-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-kvm-core-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-kvm-common-debuginfo-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-kvm-block-rbd-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-kvm-common-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-guest-agent-3.0.0-1.el8+2055+38c90e40.x86_64
qemu-kvm-block-ssh-debuginfo-3.0.0-1.el8+2055+38c90e40.x86_64

(guest)
driver version: spice-qxl-wddm-dod-0.18-1 (https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=571076)


How reproducible:
4/5


Steps to Reproduce:
1. boot guest with commands [1]
2. install driver
3. (qemu) screendump /tmp/blurred-screen

Actual results: screen dump shows blurred screen, I can't reproduced blurred screen after uninstalling qxl driver, picture will be attached to attachments 


Expected results: screen dump shows well, no blurred screen


Additional info:
[1]
/usr/libexec/qemu-kvm -name 8-w10-2017 -M pc,dump-guest-core=off -enable-kvm \
    -cpu SandyBridge \
    -monitor stdio \
    -nodefaults -rtc base=utc \
    -m 4G \
    -smp 4,sockets=2,cores=2,threads=1 \
    -nodefaults \
    -drive file=/home/8-w10/w10.qcow2,if=none,id=drive_image1,snapshot=off,aio=threads,cache=none,format=qcow2 -device virtio-blk-pci,id=image1,drive=drive_image1,bootindex=1,bus=pci.0,addr=0x4 \
    -device virtio-net-pci,mac=a4:bf:01:1e:4a:28,id=idhRa7sf,vectors=4,netdev=idNIlYmb,bus=pci.0,addr=0x5 -netdev tap,id=idNIlYmb,vhost=on \
    -drive file=/usr/share/virtio-win/virtio-win-1.9.6.iso,if=none,media=cdrom,id=ide-cdrom0 \
    -device ide-cd,drive=ide-cdrom0,id=cdrom0 \
    -qmp tcp:10.66.10.244:4444,server,nowait \
    -device ich9-usb-uhci6 \
    -device usb-tablet \
    -device qxl-vga,id=vga1 \
    -device virtio-serial-pci,id=virtio-serial1 \
    -chardev spicevmc,id=charchannel0,name=vdagent \
    -device virtserialport,bus=virtio-serial1.0,nr=3,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 \
    -spice port=5900,disable-ticketing \

Comment 1 Gerd Hoffmann 2018-12-05 07:20:20 UTC
> Steps to Reproduce:
> 1. boot guest with commands [1]
> 2. install driver
> 3. (qemu) screendump /tmp/blurred-screen

What happens if you screendump again, does the second look better?

Comment 2 liunana 2018-12-05 09:11:46 UTC
(In reply to Gerd Hoffmann from comment #1)
> > Steps to Reproduce:
> > 1. boot guest with commands [1]
> > 2. install driver
> > 3. (qemu) screendump /tmp/blurred-screen
> 
> What happens if you screendump again, does the second look better?

It's reproduced probabilistic,sometimes the second look better,sometimes the third look better.

Comment 3 Gerd Hoffmann 2018-12-05 10:23:09 UTC

*** This bug has been marked as a duplicate of bug 1018668 ***


Note You need to log in before you can comment on or make changes to this bug.