Bug 1651909 - Mess info shown up when miss credentials for samples operator with rhel installtype
Summary: Mess info shown up when miss credentials for samples operator with rhel insta...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-21 07:33 UTC by XiuJuan Wang
Modified: 2019-06-04 10:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:08 UTC

Description XiuJuan Wang 2018-11-21 07:33:47 UTC
Description of problem:
The promption is too mess after change installtype to rhel without creating credentials for registry.

Version-Release number of selected component (if applicable):

openshift/ose-cluster-samples-operator:v4.0.0-0.63.0

How reproducible:
always

Steps to Reproduce:
1.Delete initialed centos imagestreams and templates.
Edit the samplesresource to modify `managementState: Removed`
2.Make sure imagestreams and templates have been removed
3.Change installtype to rhel

#oc get samplesresource openshift-samples -o yaml
spec:
  architectures:
  - x86_64
  imagePullPolicy: ""
  imagePullSpec: ""
  installType: rhel
  logging:
    level: 0
    vmodule: ""
  managementState: Managed
4.Describe samplesresource openshift-samples

Actual results:

See detailed log here, http://pastebin.test.redhat.com/671565

Expected results:
Should prompt error explicitly

Additional info:

Comment 1 Gabe Montero 2018-11-26 22:21:45 UTC
@Xiujuan Wang - the pastebin data looks as what I would expect

SamplesExists is false, and the message starts with "Cannot create rhel imagestreams to registry.redhat.io without the credentials being available"

I'm not sure what you mean by "should prompt error explicitly"

the including of the sampleresource yaml in the error message might be a bit distracting ... i.e. the message should only say "Cannot create rhel imagestreams to registry.redhat.io without the credentials being available"

Is that what you are referring to?

Comment 2 XiuJuan Wang 2018-11-27 02:24:16 UTC
(In reply to Gabe Montero from comment #1)

> the including of the sampleresource yaml in the error message might be a bit
> distracting ... i.e. the message should only say "Cannot create rhel
> imagestreams to registry.redhat.io without the credentials being available"
> 
> Is that what you are referring to?

Yes, the sampleresource yaml in the error message is totally mess, It's better to include main import error info.

Sorry to make you confused :)

Comment 4 XiuJuan Wang 2018-11-28 08:34:26 UTC
Can't reproduce this bug with image ose-cluster-samples-operator:v4.0.0-0.74.0

Only credentials error shown, more clear.
Cannot create rhel imagestreams to registry.redhat.io without the credentials being available

Comment 7 errata-xmlrpc 2019-06-04 10:41:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.