Bug 1651980 - UC validations failed "The error was: 'a_mounts' is undefined"
Summary: UC validations failed "The error was: 'a_mounts' is undefined"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 14.0 (Rocky)
Assignee: RHOS Maint
QA Contact: Filip Hubík
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-21 10:48 UTC by Filip Hubík
Modified: 2019-01-11 11:54 UTC (History)
14 users (show)

Fixed In Version: openstack-tripleo-validations-9.3.1-0.20181008110750.4064fb7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-11 11:54:47 UTC
Target Upstream Version:
gchamoul: needinfo-


Attachments (Terms of Use)
undercloud.conf (930 bytes, text/plain)
2018-11-21 10:53 UTC, Filip Hubík
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1643029 None VERIFIED The validator " Verify undercloud fits the disk space requirements" passes when it should fail. 2019-01-09 09:48:36 UTC
Red Hat Product Errata RHEA-2019:0045 None None None 2019-01-11 11:54:58 UTC

Description Filip Hubík 2018-11-21 10:48:33 UTC
Description of problem:

Undercloud installation fails right away with error message:

uc $ openstack undercloud install
2018-11-21 05:31:48.969 8206 INFO tripleoclient.v1.undercloud_preflight.UndercloudSetup [  ] Checking Hostname...
2018-11-21 05:31:48.969 8206 INFO tripleoclient.v1.undercloud_preflight.UndercloudSetup [  ] Checking for a FQDN hostname...
2018-11-21 05:31:49.024 8206 INFO tripleoclient.v1.undercloud_preflight.UndercloudSetup [  ] Static hostname detected as undercloud-0.redhat.local
2018-11-21 05:31:49.044 8206 INFO tripleoclient.v1.undercloud_preflight.UndercloudSetup [  ] Transient hostname detected as undercloud-0.redhat.local
2018-11-21 05:31:49.044 8206 INFO tripleoclient.v1.undercloud_preflight.UndercloudSetup [  ] Checking Memory...
2018-11-21 05:31:49.045 8206 INFO tripleoclient.v1.undercloud_preflight.UndercloudSetup [  ] Checking Disk space...
2018-11-21 05:31:53.307 8206 ERROR tripleoclient.v1.undercloud_preflight.UndercloudSetup [  ] An error occurred during configuration validation, please check your host configuration and try again. Error message: Task 'debug' failed:
Host: undercloud
Message: The task includes an option with an undefined variable. The error was: 'a_mounts' is undefined

The error appears to have been in '/usr/share/openstack-tripleo-validations/validations/tasks/disk_space.yaml': line 1, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:


- name: debug
  ^ here


Failure! The validation failed for all hosts:
* undercloud

Steps to reproduce:
1) Install OSP14 using InfraRed, topology 1:1:1:1, puddle 2018-11-21.1
2) UC installation fails

Version-Release number of selected component (if applicable):
OSP14, puddle 2018-11-21.1

Additional info:
instack-undercloud.noarch 9.4.1-0.20180928005746.15cda5a.el7ost

Comment 2 Filip Hubík 2018-11-21 10:53:18 UTC
Created attachment 1507615 [details]
undercloud.conf

Comment 3 David Peacock 2018-11-21 14:22:20 UTC
Can you repro this outside of infrared?

Comment 4 Filip Hubík 2018-11-21 14:39:23 UTC
Not in reasonable time frame, since InfraRed is the only downstream OSP automation framework.

But I was able to workaround this issue with newer package manually pre-installed before UC deployment openstack-tripleo-validations-9.3.1-0.20181008110750.4064fb7.el7ost , it looks like it includes required fix - now is UC installation at least able to start and move past validations.

Comment 5 Thierry Vignaud 2018-11-22 02:11:37 UTC
Phase1 succeeded with the new build (actually with openstack-tripleo-validations-9.3.1-0.20181008110751.4064fb7.el7ost).

Comment 7 Ana Krivokapic 2018-11-22 14:16:13 UTC
This should be fixed by the fixes for bz1643029.

Comment 9 Filip Hubík 2018-11-27 14:23:00 UTC
Verified by CI and also manually that this is fixed since openstack-tripleo-validations-9.3.1-0.20181008110750.4064fb7.el7ost was included in puddle.

Comment 14 Gaël Chamoulaud 2019-01-09 09:49:53 UTC
No doc text needed.

Comment 16 errata-xmlrpc 2019-01-11 11:54:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.