Bug 1651991 - cgdcbxd policy module is missing
Summary: cgdcbxd policy module is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: selinux-policy
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 8.1
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-21 11:19 UTC by Vit Mojzis
Modified: 2020-11-14 09:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 22:09:44 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3547 0 None None None 2019-11-05 22:09:53 UTC

Description Vit Mojzis 2018-11-21 11:19:01 UTC
Description of problem:
cgdcbxd policy module is present on RHEL 7, but missing in RHEL 8. 
This might cause problems when transfering policy customizations to RHEL 8 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. # seinfo -tcgdcbxd_t -x


Actual results:
Types: 0


Expected results:
   cgdcbxd_t
      corenet_unlabeled_type
      domain
      kernel_system_state_reader
      daemon
      pcmcia_typeattr_7
      pcmcia_typeattr_6
      pcmcia_typeattr_5
      pcmcia_typeattr_4
      pcmcia_typeattr_3
      pcmcia_typeattr_2
      pcmcia_typeattr_1


Additional info:

Comment 20 Lukas Vrabec 2019-07-22 10:08:16 UTC
commit 6b93e6906d08dc4f5e267fd2288984580585b096 (HEAD -> rhel8.1-contrib, origin/rhel8.1-contrib)
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Mon Jul 22 12:01:58 2019 +0200

    Make cgdcbxd_t domain working with SELinux enforcing.
    
    Resolves: rhbz#1651991
    Allow cgdcbxd_t domain to read/write cgroups.
    Allow cgdcbxd_t domain to create unix dgram sockets

Comment 24 Lukas Vrabec 2019-08-05 10:41:19 UTC
commit ef1e1e79c3097969973dde9f2adfbf5dd27f5de0 (HEAD -> rhel8.1-contrib, origin/rhel8.1-contrib)
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Mon Aug 5 12:38:04 2019 +0200

    Allow cgdcbxd_t domain to list cgroup dirs
    Resolves: rhbz#1651991

Comment 33 errata-xmlrpc 2019-11-05 22:09:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3547


Note You need to log in before you can comment on or make changes to this bug.