Bug 1652017 - [abrt] PackageKit: repodata_add_dirstr(): packagekitd killed by SIGABRT
Summary: [abrt] PackageKit: repodata_add_dirstr(): packagekitd killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libsolv
Version: 28
Hardware: x86_64
OS: Unspecified
medium
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0647cf2f6d992d9eb79cf632b47...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-21 12:28 UTC by Syam
Modified: 2019-04-02 00:02 UTC (History)
13 users (show)

Fixed In Version: libsolv-0.7.4-1.fc29 libsolv-0.7.4-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-01 03:25:18 UTC


Attachments (Terms of Use)
File: backtrace (26.03 KB, text/plain)
2018-11-21 12:28 UTC, Syam
no flags Details
File: cgroup (184 bytes, text/plain)
2018-11-21 12:28 UTC, Syam
no flags Details
File: core_backtrace (10.39 KB, text/plain)
2018-11-21 12:28 UTC, Syam
no flags Details
File: cpuinfo (1.40 KB, text/plain)
2018-11-21 12:28 UTC, Syam
no flags Details
File: dso_list (7.76 KB, text/plain)
2018-11-21 12:28 UTC, Syam
no flags Details
File: environ (191 bytes, text/plain)
2018-11-21 12:28 UTC, Syam
no flags Details
File: limits (1.29 KB, text/plain)
2018-11-21 12:28 UTC, Syam
no flags Details
File: maps (37.76 KB, text/plain)
2018-11-21 12:28 UTC, Syam
no flags Details
File: mountinfo (3.90 KB, text/plain)
2018-11-21 12:28 UTC, Syam
no flags Details
File: open_fds (2.55 KB, text/plain)
2018-11-21 12:28 UTC, Syam
no flags Details
File: proc_pid_status (1.28 KB, text/plain)
2018-11-21 12:28 UTC, Syam
no flags Details
File: var_log_messages (720 bytes, text/plain)
2018-11-21 12:28 UTC, Syam
no flags Details

Description Syam 2018-11-21 12:28:02 UTC
Description of problem:
No specific user action. Triggered by periodic checking of updates, I guess.

Version-Release number of selected component:
PackageKit-1.1.10-1.fc28

Additional info:
reporter:       libreport-2.9.5
backtrace_rating: 4
cmdline:        /usr/libexec/packagekitd
crash_function: repodata_add_dirstr
executable:     /usr/libexec/packagekitd
journald_cursor: s=a9a9c24b10fb447fad1eb5e0f259abde;i=2b1e6c;b=cfde33e725b04160a6db2545d809f69b;m=9b0dff107;t=57b2a24479617;x=6752490ad5afc5d8
kernel:         4.18.18-200.fc28.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 1 Syam 2018-11-21 12:28:09 UTC
Created attachment 1507664 [details]
File: backtrace

Comment 2 Syam 2018-11-21 12:28:11 UTC
Created attachment 1507665 [details]
File: cgroup

Comment 3 Syam 2018-11-21 12:28:13 UTC
Created attachment 1507666 [details]
File: core_backtrace

Comment 4 Syam 2018-11-21 12:28:15 UTC
Created attachment 1507667 [details]
File: cpuinfo

Comment 5 Syam 2018-11-21 12:28:16 UTC
Created attachment 1507668 [details]
File: dso_list

Comment 6 Syam 2018-11-21 12:28:18 UTC
Created attachment 1507669 [details]
File: environ

Comment 7 Syam 2018-11-21 12:28:20 UTC
Created attachment 1507670 [details]
File: limits

Comment 8 Syam 2018-11-21 12:28:22 UTC
Created attachment 1507671 [details]
File: maps

Comment 9 Syam 2018-11-21 12:28:24 UTC
Created attachment 1507672 [details]
File: mountinfo

Comment 10 Syam 2018-11-21 12:28:26 UTC
Created attachment 1507673 [details]
File: open_fds

Comment 11 Syam 2018-11-21 12:28:28 UTC
Created attachment 1507674 [details]
File: proc_pid_status

Comment 12 Syam 2018-11-21 12:28:29 UTC
Created attachment 1507675 [details]
File: var_log_messages

Comment 13 Rafal Luzynski 2018-11-26 22:44:09 UTC
Similar problem has been detected:

This happens all the time. I have KDE and there is some background process checking for updates therefore it says that PackageKit daemon has crashed soon after the desktop login and then every several minutes later. I was trying to run pkmon on the console to check what's going on and it seems to check for updates normally and then crashes only when it reaches 99% or maybe 100%. As a result, GUI updates in my computer are impossible now, it crashes always. dnf works fine, though. I don't think there is anything unusual with my computer. Possibly it has started happening since I've installed Skype but maybe that's a wrong guess.

reporter:       libreport-2.9.5
backtrace_rating: 4
cmdline:        /usr/libexec/packagekitd
crash_function: repodata_add_dirstr
executable:     /usr/libexec/packagekitd
journald_cursor: s=fb51cb7b6adf4c43a8356a9376bcdf87;i=be1827;b=f2a0181c40b943128785eff5c473a174;m=3c7ea8d;t=57ada3a2f602d;x=87c8c83e30c67eb9
kernel:         4.18.16-200.fc28.x86_64
package:        PackageKit-1.1.10-1.fc28
reason:         packagekitd killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 14 Rafal Luzynski 2019-01-09 11:51:31 UTC
Similar problem has been detected:

This happens all the time after the computer boot (or maybe after login). PackageKit Daemon crashes whenever it tries to check for the updates. Then it retries every several minutes but always crashes. I don't remember when I was able to update anything using PackageKit last time. I must go to the command line and use dnf which works OK. I use KDE and Apper, FWIW.

reporter:       libreport-2.9.5
backtrace_rating: 4
cmdline:        /usr/libexec/packagekitd
crash_function: repodata_add_dirstr
executable:     /usr/libexec/packagekitd
journald_cursor: s=c8b2b90322234d07b9bb158c29cb5756;i=bff2d2;b=c4e0d4721d034fb69f05cb13ef3b2bcb;m=dd2f7f7b;t=57c4d6485f4cb;x=d7f4f21e6f10a194
kernel:         4.19.2-200.fc28.x86_64
package:        PackageKit-1.1.10-1.fc28
reason:         packagekitd killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 15 Kalev Lember 2019-01-09 12:00:44 UTC
Looks like libsolv crashes parsing the repodata. Reassigning to libsolv.

Comment 16 Igor Gnatenko 2019-01-12 17:23:35 UTC
I guess this might be some memory corruption.

It's definitely not a bug in libsolv, but probably rpmdb got corrupted or something like that.

If you have reproducer, please attach it and let me know (preferably on F29+).

Comment 17 Rafal Luzynski 2019-03-21 11:42:30 UTC
I dare to reopen because here is an upstream pull request: https://github.com/openSUSE/libsolv/pull/307

Comment 18 Fedora Update System 2019-03-29 16:57:41 UTC
libsolv-0.7.4-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-385da2b8ea

Comment 19 Fedora Update System 2019-03-29 16:57:55 UTC
libsolv-0.7.4-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3ebb644ae7

Comment 20 Fedora Update System 2019-03-29 20:32:42 UTC
libsolv-0.7.4-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-385da2b8ea

Comment 21 Fedora Update System 2019-03-29 22:41:28 UTC
libsolv-0.7.4-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3ebb644ae7

Comment 22 Fedora Update System 2019-04-01 03:25:18 UTC
libsolv-0.7.4-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Rafal Luzynski 2019-04-01 10:42:53 UTC
Thank you, Igor. Any chance to backport this fix to F28?

Comment 24 Fedora Update System 2019-04-02 00:02:02 UTC
libsolv-0.7.4-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.