Bug 165210 - Missing NIC entry 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 30)
Missing NIC entry 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 30)
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-05 10:16 EDT by R P Herrold
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 10:53:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2005-08-05 10:16:20 EDT
Missing NIC entry - 3 com - latest hwdata from devel tree installed


00:10.0 Non-VGA unclassified device: 3Com Corporation 3c905B 100BaseTX [Cyclone]
(rev 30)
        Subsystem: 3Com Corporation 3C905B Fast Etherlink XL 10/100
        Flags: bus master, fast devsel, latency 64, IRQ 10
        I/O ports at ec00 [size=128]
        Memory at fdafec00 (32-bit, non-prefetchable) [size=128]
        Expansion ROM at fdac0000 [disabled] [size=128K]
        Capabilities: [dc] Power Management version 1

[root@router 2.6.9-11.EL]# lspci -n
00:00.0 Class 0600: 8086:7190 (rev 03)
00:01.0 Class 0604: 8086:7191 (rev 03)
00:07.0 Class 0601: 8086:7110 (rev 02)
00:07.1 Class 0101: 8086:7111 (rev 01)
00:07.2 Class 0c03: 8086:7112 (rev 01)
00:07.3 Class 0680: 8086:7113 (rev 02)
00:0c.0 Class 0401: 1274:1371 (rev 04)
00:0f.0 Class 0200: 8086:1229 (rev 02)
00:10.0 Class 0000: 10b7:9055 (rev 30)
01:00.0 Class 0300: 1002:4742 (rev 5c)
[root@router 2.6.9-11.EL]#                


[root@router 2.6.9-11.EL]# rpm -qi hwdata ;  ifup eth1 ; lsmod | grep '3c'
Name        : hwdata                       Relocations: (not relocatable)
Version     : 0.162                             Vendor: (none)
Release     : 1                             Build Date: Fri 05 Aug 2005 10:10:03
AM EDT
Install Date: Fri 05 Aug 2005 10:12:21 AM EDT      Build Host:
router.williamscomm.com
Group       : System Environment/Base       Source RPM: hwdata-0.162-1.src.rpm
Size        : 895157                           License: GPL/MIT
Signature   : (none)
Summary     : Hardware identification and configuration data
Description :
hwdata contains various hardware identification and configuration data,
such as the pci.ids database, the X.org Cards and MonitorsDb databases.

3c59x device eth1 does not seem to be present, delaying initialization.

3c59x                  36585  0
[root@router 2.6.9-11.EL]#
Comment 1 Bill Nottingham 2005-08-05 10:50:43 EDT
hwdata now relies on drivers to properly list their pci ids.
Comment 2 John W. Linville 2005-08-15 13:55:16 EDT
10b7:9055 is certainly listed in the PCI ID table for the 3c59x driver, and  
that is exported with the MODULE_DEVICE_TABLE macro.  Bill, what else needs to 
be done to make hwdata happy?  
 
R.P., It looks like the 3c59x driver loaded.  Can you post the output of 
`ifconfig -a`?  
  
Is your e100 card working?  
  
Please also attach the output of running `sysreport`...thanks!  
Comment 3 R P Herrold 2005-08-15 20:31:27 EDT
I manually modprobed the module in, when the card was not detected, in hopes
that kudzu would then pick up the card.  It did not.

I will not have access to that host until a week from Friday.  When I return, I
will get it for you.

(I pulled the card from production, as I needed to get the unit up and dropped
in another eepro100.  I marked and set the card to one side on my bench at the
lab, so I could verify any fix.)
Comment 4 John W. Linville 2005-10-06 10:53:38 EDT
Closing due to lack of response.  Please reopen when the requested information 
is available...thanks! 

Note You need to log in before you can comment on or make changes to this bug.