Bug 1652106 - syspurpose compliance mismatch for role
Summary: syspurpose compliance mismatch for role
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 2.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: candlepin-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 1652107
TreeView+ depends on / blocked
 
Reported: 2018-11-21 15:34 UTC by Nikos Moumoulidis
Modified: 2018-11-21 16:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1652107 (view as bug list)
Environment:
Last Closed: 2018-11-21 16:16:01 UTC


Attachments (Terms of Use)

Description Nikos Moumoulidis 2018-11-21 15:34:09 UTC
Description of problem:
The consumer's syspurpose compliance is calculated wrong when the pool he is attached to has at least one role in common with the one he specified.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:

- Have a consumer with installed product "product1" and set syspurpose role to "myrole".
- Attach directly to a pool which provides product1, which has its roles product attribute set to "myrole"
- Query the syspurpose compliance.


Actual results:
The syspurpose compliance returned has status 'invalid', and has 1 item in 'partiallyCompliantProducts' and 1 item in 'reasons'.

Expected results:
The syspurpose compliance returned should have status 'valid', and should have no 'partiallyCompliantProducts' or 'reasons', since the pool supports the role that the consumer has specified (myrole).

Additional info:

The problem is in rules.js, which uses the product attribute name 'role' instead of 'roles'.


Note You need to log in before you can comment on or make changes to this bug.