Bug 1652114 - [Docs][Upgrade] 4.2 Upgrade Guide needs a section for upgrading minor versions
Summary: [Docs][Upgrade] 4.2 Upgrade Guide needs a section for upgrading minor versions
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.2.7
Hardware: All
OS: All
unspecified
urgent
Target Milestone: ovirt-4.3.1
: 4.3.0
Assignee: rhev-docs@redhat.com
QA Contact: rhev-docs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-21 15:47 UTC by Greg Scott
Modified: 2019-05-07 12:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-08 13:10:06 UTC
oVirt Team: Docs
Target Upstream Version:


Attachments (Terms of Use)

Description Greg Scott 2018-11-21 15:47:03 UTC
Description of problem:
The 4.2 Upgrade Guide has no section for upgrading minor versions. Neither does the Installation Guide

Version-Release number of selected component (if applicable):
4.2.z

How reproducible:
At will

Steps to Reproduce:
1.
2.
3.

Actual results:

I have to piece the steps together from the 4.1 to 4.2 upgrade chapter.

Expected results:

A step by step guide for how to do it.

Additional info:
This chapter could be mostly a copy and paste from other sections.  It needs:

- a section reviewing the required channels
- engine-upgrade-check
- yum update ovirt\*setup\*
- engine-setup
- yum update
- reboot

And a section for upgrading hosts including what channels to subscribe for both RHVH hosts and RHEL, and a description for how to upgrade hosts in the RHVM GUI.

Comment 1 Marina Kalinin 2018-11-21 16:48:23 UTC
I think we used to have this section before and it was removed accidentally.

Comment 3 Sandro Bonazzola 2019-01-28 09:36:56 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 5 Tahlia Richardson 2019-02-05 10:33:38 UTC
That section is still in the Upgrade Guide, but has moved to an appendix: https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.2/html-single/upgrade_guide/#Updates_between_Minor_Releases


Note You need to log in before you can comment on or make changes to this bug.