Bug 1652124 - stratis --version shows old version
Summary: stratis --version shows old version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: stratis-cli
Version: 8.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: 8.0
Assignee: mulhern
QA Contact: Storage QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-21 15:49 UTC by Jakub Krysl
Modified: 2021-09-06 15:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 21:04:23 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3414 0 None None None 2019-11-05 21:05:23 UTC

Description Jakub Krysl 2018-11-21 15:49:59 UTC
Description of problem:
Even though installed version is 1.0.1, version showed by stratis --version is 1.0.0

# stratis --version
1.0.0
# stratis daemon version
1.0.1
# rpm -qa *stratis*
stratisd-1.0.1-1.el8.x86_64
stratis-cli-1.0.1-1.el8.noarch

Version-Release number of selected component (if applicable):
stratisd-1.0.1-1.el8.x86_64
stratis-cli-1.0.1-1.el8.noarch

How reproducible:
100%

Steps to Reproduce:
1. stratis --version


Actual results:
1.0.0

Expected results:
1.0.1

Additional info:

Comment 1 Apoorv Verma 2019-01-25 10:04:02 UTC
Hello,

Same thing is observed with "stratis" version `1.0.0-2` as well :

# rpm -qa | grep -i stratis
stratis-cli-1.0.0-2.el8.noarch
stratisd-1.0.0-2.el8.x86_64

# stratis --version
1.0.0


Probably because of below file :
# head -n 3 /usr/lib/python3.6/site-packages/stratis_cli-1.0.0-py3.6.egg-info/PKG-INFO
Metadata-Version: 1.1
Name: stratis-cli
Version: 1.0.0    <<<<<

# rpm -ql stratis-cli-1.0.0-2.el8.noarch
/usr/bin/stratis
/usr/lib/python3.6/site-packages/stratis_cli
/usr/lib/python3.6/site-packages/stratis_cli-1.0.0-py3.6.egg-info
/usr/lib/python3.6/site-packages/stratis_cli-1.0.0-py3.6.egg-info/PKG-INFO    <<<<<
/usr/lib/python3.6/site-packages/stratis_cli-1.0.0-py3.6.egg-info/SOURCES.txt
/usr/lib/python3.6/site-packages/stratis_cli-1.0.0-py3.6.egg-info/dependency_links.txt
/usr/lib/python3.6/site-packages/stratis_cli-1.0.0-py3.6.egg-info/requires.txt
/usr/lib/python3.6/site-packages/stratis_cli-1.0.0-py3.6.egg-info/top_level.txt
/usr/lib/python3.6/site-packages/stratis_cli/__init__.py
/usr/lib/python3.6/site-packages/stratis_cli/__pycache__
/usr/lib/python3.6/site-packages/stratis_cli/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/__pycache__/_error_reporting.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/__pycache__/_error_reporting.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/__pycache__/_errors.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/__pycache__/_errors.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/__pycache__/_main.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/__pycache__/_main.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/__pycache__/_stratisd_constants.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/__pycache__/_stratisd_constants.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/__pycache__/_version.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/__pycache__/_version.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__init__.py
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_connection.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_connection.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_constants.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_constants.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_data.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_data.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_formatting.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_formatting.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_logical.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_logical.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_physical.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_physical.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_stratis.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_stratis.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_top.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_top.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_util.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/__pycache__/_util.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_actions/_connection.py
/usr/lib/python3.6/site-packages/stratis_cli/_actions/_constants.py
/usr/lib/python3.6/site-packages/stratis_cli/_actions/_data.py
/usr/lib/python3.6/site-packages/stratis_cli/_actions/_formatting.py
/usr/lib/python3.6/site-packages/stratis_cli/_actions/_logical.py
/usr/lib/python3.6/site-packages/stratis_cli/_actions/_physical.py
/usr/lib/python3.6/site-packages/stratis_cli/_actions/_stratis.py
/usr/lib/python3.6/site-packages/stratis_cli/_actions/_top.py
/usr/lib/python3.6/site-packages/stratis_cli/_actions/_util.py
/usr/lib/python3.6/site-packages/stratis_cli/_error_reporting.py
/usr/lib/python3.6/site-packages/stratis_cli/_errors.py
/usr/lib/python3.6/site-packages/stratis_cli/_main.py
/usr/lib/python3.6/site-packages/stratis_cli/_parser
/usr/lib/python3.6/site-packages/stratis_cli/_parser/__init__.py
/usr/lib/python3.6/site-packages/stratis_cli/_parser/__pycache__
/usr/lib/python3.6/site-packages/stratis_cli/_parser/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_parser/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_parser/__pycache__/_logical.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_parser/__pycache__/_logical.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_parser/__pycache__/_parser.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_parser/__pycache__/_parser.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_parser/__pycache__/_physical.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_parser/__pycache__/_physical.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_parser/__pycache__/_pool.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_parser/__pycache__/_pool.cpython-36.pyc
/usr/lib/python3.6/site-packages/stratis_cli/_parser/_logical.py
/usr/lib/python3.6/site-packages/stratis_cli/_parser/_parser.py
/usr/lib/python3.6/site-packages/stratis_cli/_parser/_physical.py
/usr/lib/python3.6/site-packages/stratis_cli/_parser/_pool.py
/usr/lib/python3.6/site-packages/stratis_cli/_stratisd_constants.py
/usr/lib/python3.6/site-packages/stratis_cli/_version.py
/usr/share/bash-completion
/usr/share/bash-completion/completions
/usr/share/bash-completion/completions/stratis
/usr/share/doc/stratis-cli
/usr/share/doc/stratis-cli/README.rst
/usr/share/licenses/stratis-cli
/usr/share/licenses/stratis-cli/LICENSE
/usr/share/man/man8/stratis.8.gz
/usr/share/zsh
/usr/share/zsh/site-functions
/usr/share/zsh/site-functions/_stratis


Regards !

Comment 2 mulhern 2019-01-25 22:39:39 UTC
This appears to be a packaging discrepancy. The version of the upstream package is 1.0.0, and it is reporting its own version correctly. The question is, why is the package a new version?

Comment 3 mulhern 2019-05-04 02:10:01 UTC
The answer is that the new version hasn't been set in the cli source since v1.0.0 was released.

Comment 4 Dennis Keefe 2019-05-06 18:37:11 UTC
fixed in https://github.com/stratis-storage/stratis-cli/pull/265

Comment 6 Jakub Krysl 2019-07-29 12:07:52 UTC
stratis-cli-1.0.4-2.el8.noarch

# stratis --version
1.0.4
# stratis daemon version
1.0.4

# head -n 3 /usr/lib/python3.6/site-packages/stratis_cli-1.0.4-py3.6.egg-info/PKG-INFO 
Metadata-Version: 1.1
Name: stratis-cli
Version: 1.0.4

Comment 9 errata-xmlrpc 2019-11-05 21:04:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3414


Note You need to log in before you can comment on or make changes to this bug.