Bug 165217 - "io_setup( )/io_destroy( )" have not been defined in <linux/aio.h>.
Summary: "io_setup( )/io_destroy( )" have not been defined in <linux/aio.h>.
Status: CLOSED DUPLICATE of bug 146870
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: man-pages-ja (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Akira TAGOH
QA Contact: Alexandre Petit-Bianco
URL:
Whiteboard:
Keywords:
Depends On: 146870
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-05 15:08 UTC by Brian Brock
Modified: 2010-10-22 03:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-05 15:13:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Brock 2005-08-05 15:08:01 UTC
+++ This bug was initially created as a clone of Bug #146870 +++

Description of problem:

Result is compile error, 
when we compiled our code(test.c) calling io_setup( )/io_destroy.

Error message is as follows.
---------------------------------------------------
aio.c:2:23: linux/aio.h: No such file or directory
---------------------------------------------------

So, we searched aio.h.
---------------------------------------------------
# find / -name aio.h
/lib/modules/2.6.9-1.648_EL/build/include/linux/aio.h
/usr/src/debug/kernel-2.6.9/linux-2.6.9/include/linux/aio.h
/usr/include/aio.h
---------------------------------------------------

We could not find io_setup()/io_destroy() in the headers.

Version-Release number of selected component (if applicable):
gcc-3.4.2-6.fc3
glibc-headers-2.3.3-73

How reproducible:
always

Steps to Reproduce:
1. see aio.h
2.
3.
  
Actual results:
"io_setup()/io_destroy()" have not been defined in aio.h.

Expected results:
"io_setup()/io_destroy()" have been defined in aio.h.

Additional info:
# cat test.c
---------------------------------------------------
#include <stdio.h>
#include <linux/aio.h>

main(){
int           nr_events;
long          rc;
char          *ctxp;

    nr_events = 4;
    rc = io_setup( nr_events, ctxp );
    rc = io_destroy( ctxp );
}
---------------------------------------------------

# man io_setup
---------------------------------------------------
IO_SETUP(2)                Linux Programmer's Manual              
IO_SETUP(2)

NAME
       io_setup - Create an asynchronous I/O context

SYNOPSIS
       #include <linux/aio.h>

       long io_setup (unsigned nr_events, aio_context_t *ctxp);
                            : 
                            : 
                          (snip)
                            : 
                            : 

Linux 2.4                         2003-02-21                      
IO_SETUP(2)
---------------------------------------------------

Comment 1 Brian Brock 2005-08-05 15:13:40 UTC
mistake on my part, this clone should not have been created.

closing as DUPLICATE.

*** This bug has been marked as a duplicate of 146870 ***


Note You need to log in before you can comment on or make changes to this bug.