Bug 165218 - RHEL5-rg-bug: Errors in Section 2.4.2 File Names and Blocklists
RHEL5-rg-bug: Errors in Section 2.4.2 File Names and Blocklists
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhel-sg (Show other bugs)
4.5
All Linux
medium Severity low
: ---
: ---
Assigned To: Michael Hideo
John Ha
: Documentation
Depends On:
Blocks: 148897
  Show dependency treegraph
 
Reported: 2005-08-05 11:32 EDT by Rick Sykes
Modified: 2014-08-04 18:15 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHEL 4.5 RHEL 5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 21:40:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Sykes 2005-08-05 11:32:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050721 CentOS/1.0.6-1.4.1.centos4 Firefox/1.0.6

Description of problem:
The text reads:
*********************************
The following is a sample blocklist:

0+50,100+25,200+1

This sample blocklist specifies a file that starts at the first block on the partition and uses blocks 0 through 49, 99 through 124, and 199.
***********************************
I do not know how GRUB blocklists work, but if "0+50" specifies an offset of 0 and a length of 50 blocks, (blocks 0-49 inclusive), then "100+25" should specify 25 blocks starting at 100 and "200+1" should specify 1 block starting at 200.  (The guide's text "99 through 124, and 199" should read, "100 through 124, and 200".)

A couple of sentences down, the specification

(hd0,0)+1

is described as "the chain loading file in the first partition of the first hard drive".  This is correct, as far as it goes, but the specification contains more detail.  It actually refers to "the chain loading file which is one block long and located at offset 0 in the first partition of the first hard drive".  That file is also called the Master Boot Record, and since the reference guide has already discussed the MBR in relation to GRUB, you might mention that also.

Version-Release number of selected component (if applicable):
rhel-rg(EN)-4-Print-RHI (2004-09-30T17:13)

How reproducible:
Always

Steps to Reproduce:
1.Turn to page 12.
2.Read the last 1/4 of the page.
3.
  

Actual Results:  "99 through 124" inclusive is 26 blocks

Additional info:
Comment 1 Mike Behm 2006-02-10 13:55:35 EST
Updated description as suggested.
Comment 2 Michael Hideo 2007-03-06 20:54:59 EST
Need to verify
Comment 3 Michael Hideo 2007-06-06 01:01:55 EDT
Adding ecs-dev-list@redhat.com for wider coverage
Comment 4 Don Domingo 2007-06-26 00:46:23 EDT
verified as in source. reassigning to mhideo for push to live
Comment 5 Michael Hideo 2007-10-22 22:48:43 EDT
Removing automation notification

Note You need to log in before you can comment on or make changes to this bug.