Bug 165227 - Support for graphics connections from RDP terminals
Support for graphics connections from RDP terminals
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: distribution (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: dff
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-05 12:51 EDT by Duncan Innes
Modified: 2008-08-25 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-25 12:31:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Duncan Innes 2005-08-05 12:51:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
I have now been involved in 2 major migration projects where Linux (RHEL3 & 4 specifically) were put on the table against upgrading the corporate Citrix farm.  

On both occasions, the Linux migration was beaten due to the high cost of replacing every single dumb terminal.  In the RHEL4 instance it was actually remarked that RHEL4 was preferred over Windows/Citrix due to the excellent desktop and application support.  But the dumb terminal costs proved the deciding factor in both cases.

Both corporations had bought dumb terminals which supported RDP and ICA only (being the cheapest around).

I filed a bug with X.Org, but I need to garner some support to put behind this kind of development.

If a Linux server could support connections coming from RDP-only dumb terminals, it would remove a major cost in the migration of Citrix farms.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Try and get a dumb terminal to connect to a Linux server via RDP

  

Actual Results:  It fails

Expected Results:  It would be nice if the RDP connections could be supported.  Either through an interface between the RDP connection and the X-client, or by X having a new module that would natively support RDP connections.

Additional info:

I'm not coming from a neutral standpoint here.  In both migration examples, I would have been employed as a contractor for around a year instead of the 2 months I got in each case.

I don't request this for my own good however.  It's for the greater good of Open Source.  I'm sure companies like RedHat would gain from being able to support farms of servers running X sessions.
Comment 2 Duncan Innes 2006-02-05 06:24:39 EST
Now that X.Org has been modularised in version 7.0 - is it not possible to even
have a wee look into this?

I'm not even in a situation that would benefit from RDP support any more.  It
just seems obvious to me that supporting installations that already have
hundreds of RDP only terminals would be a good thing.

Duncan
Comment 4 RHEL Product and Program Management 2008-08-25 12:31:13 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.