Bug 1652272 - core dumped on game start
Summary: core dumped on game start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gravity-beams-and-evaporating-stars
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Artur Frenszek-Iwicki
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-21 18:27 UTC by J. Randall Owens
Modified: 2018-12-01 20:40 UTC (History)
1 user (show)

Fixed In Version: gravity-beams-and-evaporating-stars-1.0-1.fc28 gravity-beams-and-evaporating-stars-1.0-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-01 02:05:34 UTC
Type: Bug


Attachments (Terms of Use)

Description J. Randall Owens 2018-11-21 18:27:45 UTC
Description of problem:
The game gets as far as displaying the initial instructions screen, but then, as soon as I 'press SPACE to start', it crashes directly.

Version-Release number of selected component (if applicable):
gravity-beams-and-evaporating-stars-0-6.20180114git3f2aa58.fc29.x86_64

How reproducible:
Unknown

Steps to Reproduce:
1. install gravity-beams-and-evaporating-stars
2. start program (from command line to see error message)
3. press space bar when instructions display

Actual results:
/usr/include/c++/8/bits/stl_vector.h:932: std::vector<_Tp, _Alloc>::reference std::vector<_Tp, _Alloc>::operator[](std::vector<_Tp, _Alloc>::size_type) [with _Tp = Asteroid; _Alloc = std::allocator<Asteroid>; std::vector<_Tp, _Alloc>::reference = Asteroid&; std::vector<_Tp, _Alloc>::size_type = long unsigned int]: Assertion '__builtin_expect(__n < this->size(), true)' failed.
Abort (core dumped)

Expected results:
I guess there's supposed to be some sort of game to play?

Additional info:
Given the error message above, I don't think it seems hardware-related, but just in case, I'm using an NVidia GeForce GTX 1050 Ti, more details available on request.
Similarly, there is an abrt directory for it in the spool; I can attach files from there if needed. (Coredump is about 300 MB, so I'd rather not pre-emptively toss it in here just in case.)

Comment 1 Artur Frenszek-Iwicki 2018-11-21 20:36:10 UTC
I just checked it on my machine and truly, it crashes as soon as the game starts - so it's definitely not hardware-related. May be related to some changes between F27 and F28, since it worked fine on the former.

Comment 2 Artur Frenszek-Iwicki 2018-11-22 11:42:38 UTC
Issue reported upstream, where it was fixed swiftly. I'll update the package and make a new build when I find a few minutes of spare time.

Comment 3 Fedora Update System 2018-11-22 12:14:53 UTC
gravity-beams-and-evaporating-stars-1.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f05030b615

Comment 4 Fedora Update System 2018-11-22 12:15:16 UTC
gravity-beams-and-evaporating-stars-1.0-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d071605cf4

Comment 5 Fedora Update System 2018-11-22 12:15:46 UTC
gravity-beams-and-evaporating-stars-1.0-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5f6b200e82

Comment 6 Fedora Update System 2018-11-23 01:16:16 UTC
gravity-beams-and-evaporating-stars-1.0-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d071605cf4

Comment 7 Fedora Update System 2018-11-23 02:02:01 UTC
gravity-beams-and-evaporating-stars-1.0-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5f6b200e82

Comment 8 Fedora Update System 2018-11-23 02:55:58 UTC
gravity-beams-and-evaporating-stars-1.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f05030b615

Comment 9 Fedora Update System 2018-12-01 02:05:34 UTC
gravity-beams-and-evaporating-stars-1.0-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2018-12-01 20:40:34 UTC
gravity-beams-and-evaporating-stars-1.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.