Bug 1652279 - Graphical boot not refreshing on external monitor
Summary: Graphical boot not refreshing on external monitor
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-21 18:57 UTC by Marko Bevc
Modified: 2019-02-22 03:13 UTC (History)
18 users (show)

Fixed In Version: plymouth-0.9.4-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-22 03:13:13 UTC


Attachments (Terms of Use)
Plymouth log file (73.14 KB, text/plain)
2018-12-02 19:17 UTC, Marko Bevc
no flags Details

Description Marko Bevc 2018-11-21 18:57:47 UTC
Description of problem:
When booting and using only external monitor initial images from notebook vendor stays on screen until XOrg login. In order to enter LUKS password I need to press Esc to get into text mode.

Version-Release number of selected component (if applicable):
Since Kernel 4.18.17+ on Lenovo X260.

How reproducible:
Reboot on external monitor.


Actual results:
Lenovo bios image.

Expected results:
LUKS password graphical boot.

Comment 1 Hans de Goede 2018-11-21 19:09:54 UTC
Hmm, that should not happen.

I've recently done some plymouth work for flickerfree boot. I've a bunch of test RPMS available here:

https://fedorapeople.org/~jwrdegoede/plymouth/

I've a blog-post with install and test instructions available here:

https://hansdegoede.livejournal.com/19673.html

Can you give these a try? And if they do not fix things, please attach /tmp/plymouth.log after a boot with the new plymouth.

Comment 2 Marko Bevc 2018-11-21 22:10:39 UTC
Oh, thanks. Is that supposed to replace currently Fedora provided packages?

plymouth-scripts-0.9.4-1.fc29.x86_64
plymouth-plugin-label-0.9.4-1.fc29.x86_64
plymouth-0.9.4-1.fc29.x86_64
plymouth-core-libs-0.9.4-1.fc29.x86_64
plymouth-graphics-libs-0.9.4-1.fc29.x86_64
plymouth-theme-charge-0.9.4-1.fc29.x86_64
plymouth-plugin-two-step-0.9.4-1.fc29.x86_64
plymouth-system-theme-0.9.4-1.fc29.x86_64


Cheers!

Comment 3 Hans de Goede 2018-11-21 22:45:07 UTC
(In reply to Marko Bevc from comment #2)
> Oh, thanks. Is that supposed to replace currently Fedora provided packages?

Yes.

Comment 4 Marko Bevc 2018-11-23 09:39:54 UTC
Before I've had a chance to test out your RPMs got upstream updates and after yesterdays push to Fedora29 stable it seems to work now here? Will test some more in next few days.

Thanks!

Comment 5 Marko Bevc 2018-11-23 09:53:54 UTC
Sorry; new update: Seems it has nothing to do with latest updates, but rather only works on fresh start after shutdown, but not a reboot or wake from hibernate.

Comment 6 Hans de Goede 2018-11-23 09:56:01 UTC
Ok, if my plymouth version does not help (I'm not sure it will) can you try adding "fbcon=nodefer" to the kernel commandline and see if that helps?

Comment 7 Marko Bevc 2018-11-25 13:17:17 UTC
Haven't really got to testing your version, but `fbcon=defer` helped. Is there a reason why we wouldn't want to connect FB right away in this is default now?

Cheers!

Comment 8 Hans de Goede 2018-11-25 14:07:13 UTC
(In reply to Marko Bevc from comment #7)
> Haven't really got to testing your version, but `fbcon=defer` helped.

Ok, I've another report of more or less the same issue. Don't bother testing my version, that won't help. I've working on a fix for this already on my todo list for Monday (tomorrow). I will get back to you when I've something for you to test.

> Is there a reason why we wouldn't want to connect FB right away in this is
> default now?

F29 is the first Fedora release to use deferred-fbcon by default, the reaosn for this is that the fbcon causes the screen to go black with a blinking cursor as soon as it boots, breaking the flickerfree boot experience we are working towards, see: https://hansdegoede.livejournal.com/19224.html

Comment 9 Hans de Goede 2018-11-28 13:55:43 UTC
I've just uploaded a new version of plymouth to:
https://fedorapeople.org/~jwrdegoede/plymouth/

Which contains fixes for the external monitor not working (as well as the new theme I've been working on).

For install instrucions see:
https://hansdegoede.livejournal.com/19673.html

If you also want to try-out the new theme, run:

sudo plymouth-set-default-theme bgrt

Before running the dracut command to regenerate the initrd.

Please let me know if this plymouth version fixes the issue for you. Once I've confirmation that this fixes things I will prepare an official Fedora plymouth update with the patches for the external monitor issue.

Comment 10 Marko Bevc 2018-12-02 11:19:12 UTC
Hi Hans!

I've tried your RPMs and I'm sorry but it doesn't seems to change anything - I've followed your instructions on your blog.

Thanks,
Marko

Comment 11 Hans de Goede 2018-12-02 11:57:49 UTC
(In reply to Marko Bevc from comment #10)
> I've tried your RPMs and I'm sorry but it doesn't seems to change anything -
> I've followed your instructions on your blog.

Can you attach the /run/plymouth.log file (from booting with an initrd which has plymouth from my rpms in there) here please?

Comment 12 Marko Bevc 2018-12-02 19:17:15 UTC
Created attachment 1510660 [details]
Plymouth log file

Comment 13 Marko Bevc 2018-12-02 19:18:03 UTC
Sure, attached - seems some libs couldn't be loaded? 

Cheers,
Marko

Comment 14 Hans de Goede 2018-12-04 09:11:16 UTC
(In reply to Marko Bevc from comment #13)
> Sure, attached - seems some libs couldn't be loaded? 

Those message can be safely ignored (I need to get rid of them one of these days).

So plymouth is seeing 1 1920x1080 screen and it is successfully initializing that screen, so you should be able to enter your password graphically one 1 screen.

I'm not entirely sure what is going on here. Some questions:

Do you have the lid of the laptop closed perhaps ?

What is the resolution of your laptop's LCD panel? and what is the resolution of the internal monitor ?

Can you also attach a plymouth.log file from a boot where the problem does not happen ?  You said that it does not happen on a cold boot, right ?

Comment 15 Hans de Goede 2018-12-04 09:17:05 UTC
One more question, how is the external monitor connected ? Is it connected through a dock using DP mst perhaps ?

Comment 16 Marko Bevc 2018-12-07 19:04:57 UTC
Sorry for late response.

Answers:
- That is probably primary screen
- Lid is closed; no password entry is visible on external screen. If I open the lid I can type there. But also if I press Esc I can enter password in text mode
- internal is 1920x1080 and LCD pandel is 2560x1440
it's connected via docking station and DP

Cold boot was working all right. Now looks even funnier - updated to newwest kernel 4.19.6 on F29 and seems to work again?!

Comment 17 Hans de Goede 2018-12-10 09:06:13 UTC
(In reply to Marko Bevc from comment #16)
> Cold boot was working all right. Now looks even funnier - updated to newwest
> kernel 4.19.6 on F29 and seems to work again?!

Ok, lets wait a bit to see if the latest kernels have really fixed this and then close this.

Comment 18 Marko Bevc 2018-12-12 21:31:05 UTC
After upgrading to 4.19.8 I've noticed same symptoms. Must be some other combination and unrelated to kernel, I reckon.

Comment 19 Hans de Goede 2019-01-21 15:57:13 UTC
Hi,

I've just built a new test build of plymouth which should help with this:

To give this a try download all rpm files from:
https://fedorapeople.org/~jwrdegoede/plymouth/
except the .src.rpm and -devel files and then from a directory with all those files in it, run:

sudo rpm -Uvh plymouth*.rpm

This version also includes a new theme which will be the default for Fedora 30, to test the new plymouth you need to regenerate your initrd, to do this (and also select the new theme) run:

sudo plymouth-set-default-theme -R bgrt

Note this updates the initrd for your currently running kernel, so if you've installed a kernel update since your last reboot, you may need to run this a second time after rebooting (check "uname -r" output before and after reboot).

Please give this a test run and let me know if it helps (or not).

Regards,

Hans

Comment 20 Marko Bevc 2019-01-22 19:10:30 UTC
Hans,

Seems this latest build is fixing it - great stuff!

Haven't really tried new theme yet; but is this build going to get in Koji for F29?

Cheers,
Marko

Comment 21 Hans de Goede 2019-01-22 20:40:02 UTC
(In reply to Marko Bevc from comment #20)
> Seems this latest build is fixing it - great stuff!

That is good to hear, thank you for testing.

> Haven't really tried new theme yet;

I made a mistake with the new theme in the build you tested, if you feel like giving the new theme a spin I've uploaded a new fixed version to:
https://fedorapeople.org/~jwrdegoede/plymouth/

> but is this build going to get in Koji for F29?

I'm still waiting for some feedback from other reporters with related issues, after that I do plan to do a plymouth update containing these fixes.

Comment 22 Fedora Update System 2019-02-13 19:54:54 UTC
plymouth-0.9.4-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-06ee37144a

Comment 23 Fedora Update System 2019-02-14 02:35:00 UTC
plymouth-0.9.4-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-06ee37144a

Comment 24 Fedora Update System 2019-02-22 03:13:13 UTC
plymouth-0.9.4-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.