Bug 165233 - Could the open source driver at76c503a be included in the next kernel release?
Could the open source driver at76c503a be included in the next kernel release?
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
http://at76c503a.berlios.de/
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-05 14:11 EDT by Ian Weedlun
Modified: 2015-01-04 17:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-05 18:27:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Weedlun 2005-08-05 14:11:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Due to the fact that it is a big annonyence to have to recompile this kernel module every time the kernel is updated, in order to gain support for my network card, could this open source driver be packaged with the kernel for future releases. The link for information on this driver can be found here: http://at76c503a.berlios.de/

I know that Mandriva already pre-packages this kernel module, and I also would like to note that even though it states on their website, only the latest CVS snapshots work with kernel 2.6, it is stable and does work (at least in my case).

Thank you for reading my request and I hope that it will be included in the next kernel release for Fedora Core!

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1398_FC4

How reproducible:
Always

Steps to Reproduce:
1. Install the latest kernel using yum update
  

Actual Results:  The kernel modules that I had compiled were lost.

Expected Results:  Those were the expected results, but not the desired ones.

Additional info:
Comment 1 Dave Jones 2005-08-05 18:27:29 EDT
maintaining non-mainline drivers in the Fedora kernel package is a maintainence
nightmare. The current ipw situation is a great example of why its a bad idea. 
Try to convince the at76c503a driver maintainers to get their code included
upstream.

Note You need to log in before you can comment on or make changes to this bug.