Bug 165234 - "yum update" runs off end of list
"yum update" runs off end of list
Status: CLOSED DUPLICATE of bug 157666
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2005-08-05 14:37 EDT by Theo Van Dinter
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-27 16:01:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Theo Van Dinter 2005-08-05 14:37:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.6 (KHTML, like Gecko) Safari/412.2

Description of problem:
I was doing a "yum update", and apparently the file being requested wasn't available on any mirror.  
After a number of "Trying other mirror." statements, the yum process crashed with:

Trying other mirror.
Traceback (most recent call last):
  File "/usr/bin/yum", line 7, in ?
  File "/usr/share/yum-cli/yummain.py", line 146, in main
  File "/usr/share/yum-cli/cli.py", line 645, in doTransaction
    problems = self.downloadPkgs(downloadpkgs) 
  File "__init__.py", line 457, in downloadPkgs
  File "repos.py", line 566, in get
  File "mirror.py", line 414, in urlgrab
  File "mirror.py", line 392, in _mirror_try
  File "mirror.py", line 290, in _get_mirror
IndexError: list index out of range

The first thing that comes to mind is that there's no bounds checking for yum mirrors and the process 
just walked off the end of the array.

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Steps to Reproduce:
1. Run "yum update", and one of the files not available on any mirror.

Expected Results:  I expected a nicer error message, or perhaps just skip the package, or download of a core Fedora server 
instead of a mirror, etc.

Additional info:
Comment 1 Rahul Sundaram 2005-08-27 16:01:41 EDT
Thanks for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 157666 ***

Note You need to log in before you can comment on or make changes to this bug.