Bug 165239 - Missing pSeries netboot images
Missing pSeries netboot images
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Mike McLean
:
: 167266 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-05 14:45 EDT by Joe Sunday
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-24 00:10:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Create netboot images again (for ppc32 and ppc64) (3.23 KB, patch)
2005-09-20 19:30 EDT, David Woodhouse
no flags Details | Diff

  None (edit)
Description Joe Sunday 2005-08-05 14:45:28 EDT
Description of problem:
images/pseries/README reads:
The files in this directory are for use in booting a pSeries 
machine.  They are as follows:
boot.iso - A bootable CD-ROM image for starting an installation on pSeries
netboot.img - A network boot image for starting an installation on pSeries
  
Actual results:
There is no netboot.img file

Expected results:
There should be a netboot.img file for netbooting
Comment 1 Jeremy Katz 2005-08-08 18:09:32 EDT
This is because we're not getting the zImage.stub stuff on the ppc64 kernel anymore.
Comment 2 David Woodhouse 2005-08-09 04:32:21 EDT
netboot.img was the combined kernel-and-initrd hack? I thought we dropped that
because yaboot was going to be fixed so it could actually load them separately?
Comment 3 David Woodhouse 2005-09-07 06:26:52 EDT
*** Bug 167266 has been marked as a duplicate of this bug. ***
Comment 4 David Woodhouse 2005-09-20 19:30:47 EDT
Created attachment 119053 [details]
Create netboot images again (for ppc32 and ppc64)

zImage.stub doesn't need to be created anew with each kernel -- it can be part
of the ppc64-utils package along with the mkzimage script. The current
ppc64-utils package is waiting in beehive with that fix.

This patch adjusts the installer accordingly. It needs to be applied on top of
the patch in bug #166625, which creates a unified boot CD.
Comment 5 David Woodhouse 2005-09-20 19:41:18 EDT
(Rationale: although yaboot _can_ be used for booting from TFTP, it's more
complicated to do it that way. Not only do you have to make yaboot itself
available by TFTP, but also the kernel and initrd and a hand-modified
yaboot.conf pointing at them. In addition to this, yaboot can't actually read
from the CD on Pegasos II machines -- so the ppc32 'netboot.img' is useful there
because it means we can still boot from the CD instead of having to hack up a
'boot.ext2'.)
Comment 6 Jeremy Katz 2005-09-24 00:10:10 EDT
Paul committed this with your other ppc changes

Note You need to log in before you can comment on or make changes to this bug.