Bug 1652425 - SELinux is preventing pool from using the 'dac_override' capabilities.
Summary: SELinux is preventing pool from using the 'dac_override' capabilities.
Keywords:
Status: CLOSED DUPLICATE of bug 1401300
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 29
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f0b90764cb54dc4ff5cb3d4aa0a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-22 04:02 UTC by mehdilaouni460
Modified: 2019-01-08 15:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-08 15:53:35 UTC


Attachments (Terms of Use)

Description mehdilaouni460 2018-11-22 04:02:44 UTC
Description of problem:
SELinux is preventing pool from using the 'dac_override' capabilities.

*****  Plugin dac_override (91.4 confidence) suggests   **********************

Si vous souhaitez identifier si le domaine nécessite cet accès ou si vous possédez un fichier avec les mauvaises permissions sur votre système
Then activez le contrôle complet pour obtenir les informations de chemin du fichier fautif et générer l'erreur à nouveau.
Do

Activer le contrôle complet
# auditctl -w /etc/shadow -p w
Tentez de recréer AVC. Puis exécutez
# ausearch -m avc -ts recent
Si vous voyez un enregistrement PATH, vérifiez les propriétés/permissions du fichier, et corrigez-les, 
sinon veuillez effectuer un rapport bugzilla.

*****  Plugin catchall (9.59 confidence) suggests   **************************

Si vous pensez que pool devrait avoir des capacités dac_override par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# ausearch -c "pool" --raw | audit2allow -M my-pool
# semodule -X 300 -i my-pool.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Objects                Unknown [ capability ]
Source                        pool
Source Path                   pool
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.2-42.fc29.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.19.2-301.fc29.i686 #1 SMP Sat
                              Nov 17 17:58:40 UTC 2018 i686 i686
Alert Count                   2
First Seen                    2018-11-22 01:43:19 +00
Last Seen                     2018-11-22 01:43:19 +00
Local ID                      095f0349-1319-44d3-a6e5-08180d4063b0

Raw Audit Messages
type=AVC msg=audit(1542850999.612:225): avc:  denied  { dac_override } for  pid=1402 comm="pool" capability=1  scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tclass=capability permissive=0


Hash: pool,thumb_t,thumb_t,capability,dac_override

Version-Release number of selected component:
selinux-policy-3.14.2-42.fc29.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.6
hashmarkername: setroubleshoot
kernel:         4.19.2-301.fc29.i686
type:           libreport

Potential duplicate: bug 1401300

Comment 1 Lukas Vrabec 2019-01-08 15:53:35 UTC

*** This bug has been marked as a duplicate of bug 1401300 ***


Note You need to log in before you can comment on or make changes to this bug.