Bug 1652493 - mod_fcgid : Requests with chunked encoding have no body available to FCGI backend
Summary: mod_fcgid : Requests with chunked encoding have no body available to FCGI bac...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mod_fcgid
Version: 7.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Web Stack Team
QA Contact: Maryna Nalbandian
URL:
Whiteboard:
Depends On:
Blocks: 1630907 1630916 1656851
TreeView+ depends on / blocked
 
Reported: 2018-11-22 09:06 UTC by Dasharath Masirkar
Modified: 2019-08-06 13:16 UTC (History)
6 users (show)

Fixed In Version: mod_fcgid-2.3.9-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1656851 (view as bug list)
Environment:
Last Closed: 2019-08-06 13:16:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Apache Bugzilla 53332 None None None 2019-04-29 12:57:37 UTC
Red Hat Product Errata RHBA-2019:2301 None None None 2019-08-06 13:16:22 UTC

Description Dasharath Masirkar 2018-11-22 09:06:28 UTC
Description of problem:
When a request with raw-body with "Transfer-Encoding: chunked",  where raw-body is a non-form data such as "application/octet-stream" sent over mod_fcgid it resulting content length is always 0 due to this FCGI CONTENT_LENGTH doesn't get set and backends don't read any of the body of the request.
Refer ASF Bug https://bz.apache.org/bugzilla/show_bug.cgi?id=53332

Version-Release number of selected component (if applicable):
mod_fcgid-2.3.9-4

How reproducible:
Always

Steps to Reproduce:
Refer ASF Bug https://bz.apache.org/bugzilla/show_bug.cgi?id=53332

Additional info:
Refer ASF Bug https://bz.apache.org/bugzilla/show_bug.cgi?id=53332

Comment 18 errata-xmlrpc 2019-08-06 13:16:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2301


Note You need to log in before you can comment on or make changes to this bug.