Bug 1652500 - Cannot get the "packagemanifest" resource by default
Summary: Cannot get the "packagemanifest" resource by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.1.0
Assignee: Evan Cordell
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-22 09:18 UTC by Jian Zhang
Modified: 2019-06-04 10:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:08 UTC

Description Jian Zhang 2018-11-22 09:18:13 UTC
Description of problem:
Cannot get the "packagemanifest" resource after creating the OCP 4.0 via openshift-installer.
[jzhang@dhcp-140-18 installer]$ oc get packagemanifest
error: the server doesn't have a resource type "packagemanifest"
And, cannot get the APIservice: "v1alpha1.packages.apps.redhat.com" either.
[jzhang@dhcp-140-18 installer]$ oc get APIservice | grep packages
[jzhang@dhcp-140-18 installer]$ 

Version-Release number of selected component (if applicable):
[jzhang@dhcp-140-18 installer]$ openshift-install version
openshift-install v0.3.0-269-gfee89558496f49e6c7e6cc7b2bb2e1d7872c0212
Terraform v0.11.8

Your version of Terraform is out of date! The latest version
is 0.11.10. You can update by downloading from www.terraform.io/downloads.html

[jzhang@dhcp-140-18 installer]$ oc exec olm-operator-67cd5c7776-n2w2j -- olm -version
OLM version: 0.8.0
git commit: 38adfbb


How reproducible:
always

Steps to Reproduce:
1. Create the OCP 4.0 (libvirt) by the openshift-instller
2. Check the "packagemanifest" resource.

Actual results:
[jzhang@dhcp-140-18 installer]$ oc get packagemanifest
error: the server doesn't have a resource type "packagemanifest"

Expected results:
The users can get the "packagemanifest" resource successfully.

Additional info:

Comment 1 Evan Cordell 2018-11-27 18:56:57 UTC
We can't replicate this on AWS - do you only see this on libvirt?

Comment 2 Jian Zhang 2018-11-30 04:14:49 UTC
Evan,

No, cannot get the "packagemanifest" resource on AWS either. AS below:
[jzhang@dhcp-140-18 aws-cluster]$ oc project openshift-operator-lifecycle-manager
Now using project "openshift-operator-lifecycle-manager" on server "https://chaoyang-api.devcluster.openshift.com:6443".

[jzhang@dhcp-140-18 aws-cluster]$ oc exec olm-operator-796dc97869-8bkzs -- olm -version
OLM version: 0.8.0
git commit: bb46d55

[jzhang@dhcp-140-18 aws-cluster]$ oc get packagemanifest
error: the server doesn't have a resource type "packagemanifest"

The cluster info:
[jzhang@dhcp-140-18 aws-cluster]$ dig chaoyang-api.devcluster.openshift.com
; <<>> DiG 9.11.4-P2-RedHat-9.11.4-10.P2.fc28 <<>> chaoyang-api.devcluster.openshift.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60676
;; flags: qr rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;chaoyang-api.devcluster.openshift.com. IN A

;; ANSWER SECTION:
chaoyang-api.devcluster.openshift.com. 60 IN A	18.235.217.147
chaoyang-api.devcluster.openshift.com. 60 IN A	54.167.150.53
chaoyang-api.devcluster.openshift.com. 60 IN A	54.160.251.126
chaoyang-api.devcluster.openshift.com. 60 IN A	52.202.250.76
chaoyang-api.devcluster.openshift.com. 60 IN A	52.204.170.91
chaoyang-api.devcluster.openshift.com. 60 IN A	54.208.97.1

;; Query time: 123 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Fri Nov 30 12:09:28 CST 2018
;; MSG SIZE  rcvd: 162

Comment 3 Fan Jia 2018-11-30 09:24:48 UTC
This problem also impact the testing of marketplace's stories.
The OLM can't load package manifest from config map csc-cm-opsrc-global-operators
what marketplace provide.

error mesg:
"
time="2018-11-30T09:00:21Z" level=info msg="retrying marketplace/csc-cs-opsrc-global-operators"
E1130 09:00:21.358582       1 queueinformer_operator.go:151] Sync "marketplace/csc-cs-opsrc-global-operators" failed: failed to load package manifest from config map csc-cm-opsrc-global-operators

"

Comment 4 Jian Zhang 2018-12-02 13:23:27 UTC
Evan,

Can you help process this issue with a high priority? Thanks!

Comment 5 Nick Hale 2018-12-05 19:21:45 UTC
Jian, 

Thanks for finding this!

We recently updated our manifests to deploy package-server via CSV (see https://jira.coreos.com/browse/ALM-812). That change has made its way to OLM's master branch and I believe that creating a fresh cluster with the installer will resolve this issue. 

Let me know how it goes :)

Comment 6 Jian Zhang 2018-12-06 03:09:41 UTC
I built a fresh cluster by using the latest installer. Yes, it works well. Please move it to "ON_QA" so that I can verify it. Thanks!
One more question, if I just want to update the OLM component, not rebuild the cluster, how can I do that?

[jzhang@dhcp-140-18 installer]$ openshift-install version
openshift-install v0.4.0-107-gbc7e5532a623a8018add448695040b46228ea145-dirty
Terraform v0.11.8

Your version of Terraform is out of date! The latest version
is 0.11.10. You can update by downloading from www.terraform.io/downloads.html

[core@jian-master-0 ~]$ oc version
oc v4.0.0-alpha.0+99b66db-755
kubernetes v1.11.0+99b66db
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://jian-api.tt.testing:6443
kubernetes v1.11.0+99b66db

[core@jian-master-0 ~]$ oc get packagemanifest
NAME                   AGE
federationv2           7m
prometheus             7m
svcat                  7m
couchbase-enterprise   7m
dynatrace-monitoring   7m
mongodb-enterprise     7m
amq-streams            7m
etcd                   7m

Comment 7 Nick Hale 2018-12-06 15:03:25 UTC
Jian, 

Awesome!

So, from what I understand, you'll first need to disable the CVO (by deleting its Deployment) to prevent it from undoing any changes you make to OLM. Then you can kubectl apply/create/replace -f  the output of the ./scripts/package-release.sh script to the appropriate namespace. 

Let me know if you have any more questions.

Comment 8 Jian Zhang 2018-12-07 01:47:50 UTC
Nick,

Got it! Thanks a lot! Verify this bug per comment6.

Comment 11 errata-xmlrpc 2019-06-04 10:41:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.