Bug 1652507 - [RFE] Export/Import CV filter
Summary: [RFE] Export/Import CV filter
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Inter Satellite Sync
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 1644596
TreeView+ depends on / blocked
 
Reported: 2018-11-22 09:26 UTC by Jitendra Yejare
Modified: 2019-08-12 19:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-28 20:48:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jitendra Yejare 2018-11-22 09:26:55 UTC
Description of problem:
Currently, CV verion with filtered contents only are exported and imported(as expected and without creating same filters in importing org), but the actual filters are not imported.

Can we add support to export and import CV version with filters? 

Version-Release number of selected component (if applicable):
Satellite 6.5.0 snap 3

How reproducible:


Steps to Reproduce:
1. Create CV with filter and publish.
2. Export CV version published above.
3. Attempt to import the CV version from another satellite/org.

Actual results:
The CV with filter version is exported and imported with filtered contents, but the actual filter is not exported/imported.

Expected results:
The CV with filter version is exported and imported with filtered contents along with filter.

Additional info:

Comment 1 Eric Helms 2018-11-28 20:48:41 UTC
Filters are not associated to a content view version, they are associated with the content view itself. The filters for a given version are not saved in the database. Thus, a content view has filters that could have changed since a version was published. If we were exporting content view definitions we could export the most recent filters but they may not be relevant to an exported version.


Note You need to log in before you can comment on or make changes to this bug.