Bug 165251 - Kickstart with NFS driverdisk fails with loop problem
Kickstart with NFS driverdisk fails with loop problem
Status: CLOSED DUPLICATE of bug 127072
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-05 17:00 EDT by Chris Kloosterman
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-08 18:10:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Kloosterman 2005-08-05 17:00:16 EDT
Description of problem:

We're trying to get a kickstart install going with a boot cd, install tree
available through NFS.  We have some hardware that doesn't work automatically in
RHEL 3 (an Adaptec AIC-9410 using the adp94xx driver).  It comes with a driver
disk image, so we have attempted to use this with the kickstart install.

When booting off of the CD, we use the following boot parameters (from
isolinux.cfg):

  kernel linuzas
  append initrd=initrdas.img ks=nfs:(server):/home/kickstart/rhel3_as.ks
ksdevice=eth0

The rhel3_as.ks file has the following driverdisk line:

driverdisk
--source=nfs:(server):/home/kickstart/dist/adp94xx-0.0.5-7.rhel3qu4.i686.img

We have also tried distributing the file through http:

driverdisk --source=http://(server)~kloostec/adp94xx-0.0.5-7.rhel3qu4.i686.img

The problem is that the installer cannot mount the image file using either NFS
or HTTP distribution.  I can mount it file on my FC4 machine, it's just in the
RHEL installer.  It copies the file to /tmp/dd.img just fine; the problem is
something to do with "cannot assign a loopback device" when it actually tries to
mount the disk to /tmp/drivers.  It appears to be trying to use /tmp/loop6.  I
checked /tmp and loop6 is there, with the proper node and subnode.

Is there any way around this problem, or can it be fixed?

Version-Release number of selected component (if applicable):

RHEL 3.0 update 4

How reproducible:

Always

Steps to Reproduce:
1. Set up a kickstart with installation over NFS
2. Set up a driverdisk line, and distribute the image over NFS, too
3. Boot up the kickstart installation
  
Actual results:

Cannot mount driverdisk.

Expected results:

Drivers extracted from the driverdisk image, hard drives detected, install to
continue painlessly.
Comment 1 Chris Kloosterman 2005-08-05 17:08:56 EDT
Note: this is RHEL3 U4, as that's the latest version of the kernel driver that
we can get for the hardware.

The exact error is:

* mntloop loop6 on /tmp/drivers as /tmp/dd.img fd is 36
* failed to mount loop: Invalid argument
Comment 2 Chris Kloosterman 2005-08-05 20:10:09 EDT
This seems to be the same bug as Bug 127072, but that bug was apparently fixed a
year ago.  Confirmed that the same fix (creating an ext2 disk image) fixes the
problem.
Comment 3 Jeremy Katz 2005-08-08 18:10:19 EDT
For RHEL3, you need to use ext2 formatted driver disks in this case.

*** This bug has been marked as a duplicate of 127072 ***

Note You need to log in before you can comment on or make changes to this bug.