Bug 165252 - System freezes completely when printing
System freezes completely when printing
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-05 17:33 EDT by Guo Yang
Modified: 2015-01-04 17:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-05 18:40:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output from lspci -v (4.55 KB, text/plain)
2005-08-05 17:36 EDT, Guo Yang
no flags Details
Output from dmesg under kernel 2.6.12-1.1398_FC4smp (12.11 KB, text/plain)
2005-08-05 17:37 EDT, Guo Yang
no flags Details

  None (edit)
Description Guo Yang 2005-08-05 17:33:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050729 Fedora/1.1-0.2.5.deerpark.alpha2 Firefox/1.0+

Description of problem:
I update my system regularly against the develepment branch of Fedora Core. I noticed that all SMP kernels after kernel-smp-2.6.12-1.1421_FC5 (not included) have this same problem: The machine will freeze completely sooner or later when I print anyting from any program. Although at the beginning I noticed the problem when I printed something from acroread 7.0, later I tried other programs like Firefox, Evolution and they all could cause the problem. When that happened, the power was on, but the display would keep the display before froze, keyboard did not respond to Ctrl-Alt-Del or anything else, and the machine didn't respond to ping. The /var/log/messages did not have any error messages around the freeze up
time. 

And when I processed data with IDL (interactive data language), the program would have a segmentation fault (This I only happened with version: kernel-smp-2.6.12-1.1448_FC5, I didn't try other versions.) But with exactly same program and same dataset, there was no problem under kernel kernel-smp-2.6.12-1.1421_FC5.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.12-1.1451_FC5

How reproducible:
Always

Steps to Reproduce:
1.Boot the machine.
2.Start a program: acroread or Evolution or Firefox and try to print something. If the machine doesn't freeze then try again.
3.Then eventually (not very long) the machine will freeze when print icon appears on the panel.
  

Actual Results:  The computer will freeze with the display when it happens. Power down and up again are needed to bring it back. No network connection or whatever.

Expected Results:  The file should be printed normally.

Additional info:
Comment 1 Guo Yang 2005-08-05 17:36:21 EDT
Created attachment 117503 [details]
Output from lspci -v
Comment 2 Guo Yang 2005-08-05 17:37:56 EDT
Created attachment 117504 [details]
Output from dmesg under kernel 2.6.12-1.1398_FC4smp
Comment 3 Guo Yang 2005-08-05 18:00:14 EDT
I forgot to mention that my machine's specs. It's a Dell Optiplex GX270 with
Intel Pentium 4 CPU working at 3.20GHz. The HyperThread is enabled. The system
has 2 Gig memory. I use nVidia driver 7667 which is faily stabl now. I am not
sure if the problem caused by this driver. Kernel-smp version before 1421 all
works fine.

Also I noticed that if I move the mouse after I print something, it is more
easily to happen.
Comment 4 Dave Jones 2005-08-05 18:40:44 EDT
We've seen many reports of hangs with the nvidia driver. They're unfortunatly
impossible for us to diagnose.  Unless you can repeat it without it loaded,
there's nothing we can do.


*** This bug has been marked as a duplicate of 73733 ***
Comment 5 Guo Yang 2005-08-06 09:50:34 EDT
Thank you Dave for prompt reply. I just tried to run the system without the
nvidia binary module. Here is what I did:

1.I edited xorg.conf and commented the line with: Driver "nvidia"
and change it to: Driver "nv". Then I commented other lines related to this
driver and then restart the machine.

2. After the restart I launched firefox and opened the ups.com's home page and
tried to print it. Right after I hit the print menu item, I started to move the
mouse around. 3 or 4 seconds later the machine froze again (In the first 2
seconds I was thinking it would be fine.)

I am not sure if it is enough to disable the nvidia binary module by just
changing the xorg.conf.

I tried to search similar problem but failed. And because there is no any
diagnostic information so I will not expect it fixed very soon. I will keep
trying every new kernel and see if it will be gone.

Dave, I am wondering if you still have the kernel-smp-devel-2.6.12-1.1421_FC5
package. I deleted it accidently. I tried to find it on google but it seems that
every repository has updated to latest ones. This one doesn't give me any
problem and runs much better than kernel-smp-2.6.12-1.1398_FC4 especially under
heavy load. 

Note You need to log in before you can comment on or make changes to this bug.