Bug 1652533 - Engine UI Gives 404
Summary: Engine UI Gives 404
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ovirt-4.3.0
: ---
Assignee: Sandro Bonazzola
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-22 10:26 UTC by Anton Marchukov
Modified: 2019-05-08 12:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-08 12:39:01 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:1085 0 None None None 2019-05-08 12:39:14 UTC

Description Anton Marchukov 2018-11-22 10:26:59 UTC
Description of problem:

When trying to access ovirt engine UI HTTP 404 is returned for "/ovirt-engine" url while the redirect from "/" works.

Version-Release number of selected component (if applicable):
4.3.0

How reproducible:
Always

Steps to Reproduce:
1. Install 4.3.0.
2. Run engine-setup
3. Go to engine UI.

Actual results:
404 - Not Found


Expected results:
Engine UI appears

Comment 3 Yedidyah Bar David 2018-11-22 10:38:24 UTC
server.log has:

2018-11-22 04:16:12,170-05 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 25) WFLYSRV0010: Deployed "ovirt-web-ui.war" (runtime-name : "ovirt-web-ui.war")
2018-11-22 04:16:12,170-05 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 25) WFLYSRV0010: Deployed "rhv.ear" (runtime-name : "rhv.ear")
2018-11-22 04:16:12,170-05 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 25) WFLYSRV0010: Deployed "apidoc.war" (runtime-name : "apidoc.war")
2018-11-22 04:16:12,170-05 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 25) WFLYSRV0010: Deployed "restapi.war" (runtime-name : "restapi.war")
2018-11-22 04:16:12,170-05 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 25) WFLYSRV0010: Deployed "engine.ear" (runtime-name : "engine.ear")
2018-11-22 04:16:12,183-05 INFO  [org.jboss.as.controller] (Controller Boot Thread) WFLYCTL0183: Service status report
WFLYCTL0184:    New missing/unsatisfied dependencies:
      service jboss.naming.context.java.global.engine.bll."Backend!org.ovirt.engine.core.common.interfaces.BackendLocal" (missing) dependents: [service jboss.naming.context.java.module.restapi.restapi.env."org.ovirt.engine.core.utils.servlet.CORSSupportFilter".backend, service jboss.naming.context.java.module.restapi.restapi.env."org.ovirt.engine.api.restapi.invocation.CurrentFilter".backend, service jboss.naming.context.java.module.restapi.restapi.env."org.ovirt.engine.api.restapi.invocation.VersionFilter".backend] 
WFLYCTL0186:   Services which failed to start:      service jboss.module.service."deployment.engine.ear".main: WFLYSRV0179: Failed to load module: deployment.engine.ear
      service jboss.module.service."deployment.engine.ear.services.war".main: WFLYSRV0179: Failed to load module: deployment.engine.ear.services.war
      service jboss.module.service."deployment.engine.ear.enginesso.war".main: WFLYSRV0179: Failed to load module: deployment.engine.ear.enginesso.war
      service jboss.module.service."deployment.engine.ear.bll.jar".main: WFLYSRV0179: Failed to load module: deployment.engine.ear.bll.jar
      service jboss.module.service."deployment.engine.ear.docs.war".main: WFLYSRV0179: Failed to load module: deployment.engine.ear.docs.war
      service jboss.module.service."deployment.engine.ear.welcome.war".main: WFLYSRV0179: Failed to load module: deployment.engine.ear.welcome.war
      service jboss.module.service."deployment.engine.ear.root.war".main: WFLYSRV0179: Failed to load module: deployment.engine.ear.root.war
      service jboss.module.service."deployment.engine.ear.webadmin.war".main: WFLYSRV0179: Failed to load module: deployment.engine.ear.webadmin.war

2018-11-22 04:16:12,305-05 INFO  [org.jboss.as.server] (Controller Boot Thread) WFLYSRV0212: Resuming server
2018-11-22 04:16:12,307-05 INFO  [org.jboss.as] (Controller Boot Thread) WFLYSRV0060: Http management interface listening on http://127.0.0.1:8706/management
2018-11-22 04:16:12,307-05 INFO  [org.jboss.as] (Controller Boot Thread) WFLYSRV0051: Admin console listening on http://127.0.0.1:8706
2018-11-22 04:16:12,307-05 ERROR [org.jboss.as] (Controller Boot Thread) WFLYSRV0026: JBoss EAP 7.1.5.GA (WildFly Core 3.0.19.Final-redhat-00001) started (with errors) in 9174ms - Started 715 of 1012 services (36 services failed or missing dependencies, 382 services are lazy, passive or on-demand)

Comment 4 Yedidyah Bar David 2018-11-22 10:40:03 UTC
And before that:

Caused by: org.jboss.modules.xml.XmlPullParserException: Failed to add resource root 'nimbus-jose-jwt.jar' at path 'nimbus-jose-jwt.jar' (position: END_TAG seen ...<resources>\n    <resource-root path="nimbus-jose-jwt.jar"/>... @6:48) caused by: java.io.FileNotFoundException: /usr/share/ovirt-engine/modules/common/com/nimbusds/main/nimbus-jose-jwt.jar (No such file or directory)
        at org.jboss.modules.xml.ModuleXmlParser.parseResourceRoot(ModuleXmlParser.java:1006)
        at org.jboss.modules.xml.ModuleXmlParser.parseResources(ModuleXmlParser.java:850)
        at org.jboss.modules.xml.ModuleXmlParser.parseModuleContents(ModuleXmlParser.java:645)
        at org.jboss.modules.xml.ModuleXmlParser.parseDocument(ModuleXmlParser.java:416)
        at org.jboss.modules.xml.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:296)
        ... 25 more
Caused by: java.io.FileNotFoundException: /usr/share/ovirt-engine/modules/common/com/nimbusds/main/nimbus-jose-jwt.jar (No such file or directory)

Comment 5 Sandro Bonazzola 2018-11-22 10:59:04 UTC
Thanks, I'm fixing this.

Comment 6 Sandro Bonazzola 2018-11-22 11:01:42 UTC
Fixed in downstream spec file, upstream is not affected.

Comment 7 Raz Tamir 2018-11-26 15:56:17 UTC
Verified on 4.3.0-0.5.alpha1.el7
UI is working as expected

Comment 8 RHV bug bot 2018-12-10 15:13:11 UTC
WARN: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.com

Comment 9 RHV bug bot 2019-01-15 23:35:39 UTC
INFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[No relevant external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 11 errata-xmlrpc 2019-05-08 12:39:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1085


Note You need to log in before you can comment on or make changes to this bug.