Bug 165255 - clvm rpm missing dependency on mkinitrd
clvm rpm missing dependency on mkinitrd
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-05 18:05 EDT by Adam "mantis" Manthei
Modified: 2010-01-11 23:03 EST (History)
2 users (show)

See Also:
Fixed In Version: U2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 14:38:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam "mantis" Manthei 2005-08-05 18:05:18 EDT
Description of problem:
In order to create an initrd that doesn't panic when upgrading a system that has
already been configured for clvm (i.e. locking_library = "liblvm2clusterlock.so"
 and locking_type = 2), mkinitrd with the "--ignorelockingfailure" option
appended to the lvm command is needed. 

Since panicking systems due to upgrading the lvm and kernel packages has been
addressed by mkinitrd (bug #151172), it should be an obvious requirement to make
clvm's package depend on it.


Version-Release number of selected component (if applicable):
# rpm -qa | grep lvm
lvm2-cluster-2.01.09-5.0.RHEL4
system-config-lvm-0.9.18-1.0
lvm2-2.01.14-1.0.RHEL4


How reproducible:
everytime

Steps to Reproduce:
1. have mkinitrd older than 4.2.1.2-1 installed
2. install lvm2-cluster
3. upgrade kernel

  
Actual results:
without the dependency, an initrd can be created with clustering enabled in
/etc/lvm/lvm.conf that will cause the lvm tools to fail, resulting in a system panic

Expected results:
system boots after upgrading lvm2 and lvm2-cluster

Additional info:
The initrd issue is fixed in mkinitrd version 4.2.1.3-1
# grep ignore /sbin/mkinitrd
         # ignore the absence of the scsi modules
     echo "lvm vgscan --ignorelockingfailure" >> $RCFILE
     echo "lvm vgchange -ay --ignorelockingfailure $root_vg" >>            $RCFILE

#rpm -qa | grep mkinitrd
mkinitrd-4.2.1.3-1
Comment 1 Adam "mantis" Manthei 2005-08-05 18:06:20 EDT
assigning to package maintainer (agk)
Comment 3 Alasdair Kergon 2005-08-16 16:14:46 EDT
Adding to 2.01.09-6

Note You need to log in before you can comment on or make changes to this bug.