Bug 1652571 - [RFE][kuryr] Default kuryr images are hosted in docker.io instead redhat's registry (and using latest)
Summary: [RFE][kuryr] Default kuryr images are hosted in docker.io instead redhat's re...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.11.z
Assignee: Luis Tomas Bolivar
QA Contact: Jon Uriarte
URL:
Whiteboard:
: 1745195 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-22 11:56 UTC by Eduardo Minguez
Modified: 2020-01-14 05:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-14 05:31:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift openshift-ansible pull 11925 'None' 'closed' 'Modify the default kuryr images' 2019-12-04 07:54:16 UTC
Red Hat Product Errata RHBA-2020:0017 None None None 2020-01-14 05:31:39 UTC

Description Eduardo Minguez 2018-11-22 11:56:05 UTC
Description of problem: https://github.com/openshift/openshift-ansible/blob/master/roles/kuryr/defaults/main.yaml#L34-L36

If using RHEL, the images should be pulled from redhat's registry instead (and properly tagged)

Version-Release number of the following components:
[cloud-user@shiftstack-ansibler ~]$ rpm -q openshift-ansible
openshift-ansible-3.11.43-1.git.0.fa69a02.el7.noarch
[cloud-user@shiftstack-ansibler ~]$ rpm -q ansible
ansible-2.5.7-1.el7ae.noarch
[cloud-user@shiftstack-ansibler ~]$ ansible --version
ansible 2.5.7
  config file = /home/cloud-user/ansible.cfg
  configured module search path = [u'/home/cloud-user/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, Sep 12 2018, 05:31:16) [GCC 4.8.5 20150623 (Red Hat 4.8.5-36)]

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Images are downloaded from the docker.io registry

[openshift@master-0 ~]$ sudo docker images
REPOSITORY                                        TAG                 IMAGE ID            CREATED             SIZE
registry.redhat.io/openshift3/ose-node            v3.11               901c817d48cc        10 days ago         1.17 GB
registry.redhat.io/openshift3/ose-control-plane   v3.11               e043f4037c7f        10 days ago         807 MB
registry.redhat.io/openshift3/ose-pod             v3.11               47ea091bca33        10 days ago         238 MB
registry.redhat.io/openshift3/ose-pod             v3.11.43            47ea091bca33        10 days ago         238 MB
registry.redhat.io/rhel7/etcd                     3.2.22              b52c3d52a9b7        3 weeks ago         259 MB
docker.io/kuryr/cni                               latest              3e5e7fba6db9        6 weeks ago         818 MB


Expected results:

Image hosted in the redhat's registry and tagged as the openshift version (v3.11)

[openshift@master-0 ~]$ sudo docker images
REPOSITORY                                        TAG                 IMAGE ID            CREATED             SIZE
registry.redhat.io/openshift3/ose-node            v3.11               901c817d48cc        10 days ago         1.17 GB
registry.redhat.io/openshift3/ose-control-plane   v3.11               e043f4037c7f        10 days ago         807 MB
registry.redhat.io/openshift3/ose-pod             v3.11               47ea091bca33        10 days ago         238 MB
registry.redhat.io/openshift3/ose-pod             v3.11.43            47ea091bca33        10 days ago         238 MB
registry.redhat.io/rhel7/etcd                     3.2.22              b52c3d52a9b7        3 weeks ago         259 MB
registry.redhat.io/openshift3/kuryr-cni                               v3.11              3e5e7fba6db9        6 weeks ago         818 MB


Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Eduardo Minguez 2018-11-22 14:40:43 UTC
I'm thinking about doing something similar to https://github.com/openshift/openshift-ansible/blob/master/roles/olm/defaults/main.yaml so depending on the openshift_deployment_type variable, it will pull the image from redhat's registry or upstream.

Comment 2 Luis Tomas Bolivar 2019-09-25 15:48:05 UTC
*** Bug 1745195 has been marked as a duplicate of this bug. ***

Comment 5 Jon Uriarte 2019-12-17 09:28:42 UTC
Verified in v3.11.156-1_2019-11-25.1 OCP puddle on OSP 13 2019-11-04.1 puddle.

Kuryr images are now stored in red hat registry and tagged with 3.11:

registry.redhat.io/openshift3/kuryr-controller:v3.11
registry.redhat.io/openshift3/kuryr-cni:v3.11


In dev phase we use registry.reg-aws.openshift.com registry:

registry.reg-aws.openshift.com:443/openshift3/ose-kuryr-controller:v3.11
registry.reg-aws.openshift.com:443/openshift3/ose-kuryr-cni:v3.11

Comment 7 errata-xmlrpc 2020-01-14 05:31:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0017


Note You need to log in before you can comment on or make changes to this bug.