Bug 165264 - When installing openssl into a chroot two links are missing.
When installing openssl into a chroot two links are missing.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-08-06 01:14 EDT by Bob Kashani
Modified: 2014-01-21 17:52 EST (History)
0 users

See Also:
Fixed In Version: openssl-0.9.7f-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-23 11:34:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
yum chroot script (2.53 KB, text/plain)
2005-08-14 12:45 EDT, Bob Kashani
no flags Details

  None (edit)
Description Bob Kashani 2005-08-06 01:14:34 EDT
Description of problem:
When installing openssl into a chroot two links are missing.

/lib/libcrypto.so.5
/lib/libssl.so.5

This issue seems to have occurred before:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=51630

Version-Release number of selected component (if applicable):
openssl-0.9.7f-7

How reproducible:
Install openssl into a chroot via yum.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tomas Mraz 2005-08-07 13:33:30 EDT
Most probably a ldconfig binary is missing in the chroot? It would have created
the links otherwise.

However I agree that the symlinks should be included.
Comment 2 Bob Kashani 2005-08-10 23:42:01 EDT
I'm installing into a chroot via "yum -y --installroot=/mychroot groupinstall
Base" so it seems a little odd that /sbin/ldconfig is missing. On the other hand
I don't know whether YUM is installing openssl before glibc or not (I'll check
tonight)? If that is the case wouldn't it be a good idea to add a "Requires:
/sbin/ldconfig" to the spec file?
Comment 3 Tomas Mraz 2005-08-11 02:44:04 EDT
This is strange because there is implicit requires on /sbin/ldconfig for post
script which is generated automatically by RPM. (So the ldconfig must be
installed before the post script is run.) So there must be some other bug. You
could try to remove openssl from the root and try to install it again if the
ldconfig will run or not.

If it run in such case it would be a yum or rpm bug then.
Comment 4 Bob Kashani 2005-08-12 22:53:09 EDT
I just noticed that I have this in my yum.conf file:

tsflags=noscripts notriggers

BUT...if I remove the tsflags line I get a bunch of errors like this:

error: %post(openssl-0.9.7f-7.686) scriptlet failed, exit status 255

Also, I checked and yum is installing glibc as the fourth or fifth package so
ldconfig is there.

But if I install the openssl rpm using rpm:

rpm --root /mychroot -Uvh --nodeps --force openssl-0.9.7f-7.i686.rpm

The symlinks are created and I get no errors during install.

So is this a yum bug?

rpm-4.4.1-22
yum-2.3.4-1
Comment 5 Seth Vidal 2005-08-14 00:47:18 EDT
that error occurs when /proc or portions of /dev are not mounted. I can't
remember which. This is why mock, for example, mounts up /proc, /sys and
/selinux along with making certain devices in /dev before continuing.
Comment 6 Bob Kashani 2005-08-14 12:45:43 EDT
Created attachment 117716 [details]
yum chroot script

Seth, I looked thru /usr/bin/mock and I've tried everything that I can thing of
and it still doesn't work. Attached is my script so you can see it. What am I
missing?
Comment 7 Seth Vidal 2005-08-14 14:27:52 EDT
so my first question is:
1. is selinux set to enforcing or warn in /etc/selinux/config and is it enabled
or disabled in the kernel?

2. for what you're doing why not just use mock?
Comment 8 Bob Kashani 2005-08-15 00:03:00 EDT
1. Yes, selinux is enabled and in enforcing...(default FC4 targeted install)

2. I wish I could for this project but I can't. I need things to work on
multi-distros eventuallly and a mock/python deps could add too much complexity.
I'm still in experimental phase so things could change.

Will a 'mock -r mychroot.cfg init' create a clean chroot for me based on what I
place in mychroot.cfg?
Comment 9 Seth Vidal 2005-08-15 00:08:07 EDT
1. disable selinux and see if the problem goes away - I bet it will
2. if you have the deps for yum then you have the deps for mock.

'mock -r mychroot init' will make  chroot for you based on what's in
/etc/mock/mychroot.cfg


Comment 10 Bob Kashani 2005-08-15 01:01:44 EDT
1. disabling selinux fixes the problem. why?
2. hrmm...you have s point there...

could I do this: 'mock -r /path/to/mychroot.cfg init' It would be much easier if
I could point to my own config file in my project tree.
Comment 11 Seth Vidal 2005-08-15 01:06:27 EDT
1. b/c you don't have rights to write to that location or run things from there,
iirc.
2. just put a file whereever and make a symlink to it in /etc/mock/



Note You need to log in before you can comment on or make changes to this bug.