Bug 1652696 - overcloud deploy does not report cause of workflow failures to operator
Summary: overcloud deploy does not report cause of workflow failures to operator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z1
: 14.0 (Rocky)
Assignee: Zane Bitter
QA Contact: Ronnie Rasouli
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-22 15:52 UTC by Thomas Hervé
Modified: 2019-03-18 13:01 UTC (History)
11 users (show)

Fixed In Version: openstack-heat-11.0.1-0.20181010161428.46aacab.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the OS::Mistral::ExternalResource resource type did not report the text of any error in the execution of a Mistral workflow. This led to incomplete ERROR messages if a Mistral workflow failed. This fix adds the execution `state_info` content to the error message, which shows the reason for the workflow failure.
Clone Of: 1647286
Environment:
Last Closed: 2019-03-18 13:01:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 619200 0 None None None 2018-11-22 15:52:07 UTC
Red Hat Product Errata RHBA-2019:0589 0 None None None 2019-03-18 13:01:22 UTC

Description Thomas Hervé 2018-11-22 15:52:08 UTC
+++ This bug was initially created as a clone of Bug #1647286 +++

When a Mistral workflow fails during the overcloud deployment, the error is reported to the operator like this:

    overcloud.AllNodesDeploySteps.WorkflowTasks_Step5_Execution:
      resource_type: OS::TripleO::WorkflowSteps
      physical_resource_id: 3a0b5696-8f20-4d05-9222-0b9a7d763fc6
      status: CREATE_FAILED
      status_reason: |
        resources.WorkflowTasks_Step5_Execution: ERROR
    Heat Stack update failed.
    Heat Stack update failed.

This doesn't provide the operator with any information about the cause of the failure.  This is generally reported in mistral logs (engine.log, execution.log).  These failures should be collected by the mistral api, if they're not already, and then communicated to the operator.

--- Additional comment from Steve Baker on 2018-11-19 16:46:23 EST ---

Thomas, you may have the unique skills to improve the error path feedback from heat->mistral->user, let us know if you can take this bug.

Comment 5 errata-xmlrpc 2019-03-18 13:01:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0589


Note You need to log in before you can comment on or make changes to this bug.