Bug 165271 - Evolution misreports SMTP error
Evolution misreports SMTP error
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-06 06:12 EDT by David Woodhouse
Modified: 2007-12-11 08:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 05:52:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 248873 None None None Never
GNOME Desktop 341579 None None None Never

  None (edit)
Description David Woodhouse 2005-08-06 06:12:06 EDT
When attempting to send mail, Evolution reported that sending the message failed
after DATA: "Operation now in progress". This error message was made up by
Evolution and is meaningless. The mail server presented human-readable text
which Evolution failed to display.

I ran Evolution again with CAMEL_VERBOSE_DEBUG=1 but the mail went through on
the second attempt, and the information about what went wrong was lost.

Evolution should report the error message it receives from the SMTP server; it
shouldn't make up its own.

This problem was mentioned as an aside in bug #151121, but warrants a separate
bug report of its own.
Comment 1 Matthew Barnes 2007-10-04 23:20:31 EDT
Have you seen this problem on recent versions of Evolution (Fedora 7 or later)?

I notice one of the two upstream bugs linked to from here has been fixed.
Comment 2 David Woodhouse 2007-10-22 06:05:42 EDT
The second bug (which is still open) is a duplicate of the first, which was
closed by Jeff just because it was me who reported it, AFAICT. The problem still
exists.
Comment 3 Matěj Cepl 2007-12-10 16:47:59 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Evolution.
If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 5 Milan Crha 2007-12-11 05:52:32 EST
Closing this as upstream, we will track it in GN-bug #341579.

Note You need to log in before you can comment on or make changes to this bug.