Bug 1652766 - SSSD crashes with talloc_chunk_from_ptr failure
Summary: SSSD crashes with talloc_chunk_from_ptr failure
Keywords:
Status: CLOSED DUPLICATE of bug 1683946
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.5
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: SSSD Maintainers
QA Contact: sssd-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-23 00:49 UTC by Vinay Mishra
Modified: 2019-03-13 22:23 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-13 22:23:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vinay Mishra 2018-11-23 00:49:04 UTC
(gdb) info threads 
  Id   Target Id         Frame 
* 1    Thread 0x7fd791749880 (LWP 50308) talloc_chunk_from_ptr (ptr=0x1) at ../talloc.c:521
(gdb) t 1
[Switching to thread 1 (Thread 0x7fd791749880 (LWP 50308))]
#0  talloc_chunk_from_ptr (ptr=0x1) at ../talloc.c:521
521		if (unlikely((tc->flags & (TALLOC_FLAG_FREE | ~TALLOC_FLAG_MASK)) != talloc_magic)) {

(gdb) bt full
#0  talloc_chunk_from_ptr (ptr=0x1) at ../talloc.c:521
        pp = 0x1 <Address 0x1 out of bounds>
        tc = <optimized out>
#1  __talloc_with_prefix (tc_ret=<synthetic pointer>, prefix_len=0, size=24, context=0x1) at ../talloc.c:743
        tc = 0x0
        limit = 0x0
        total_len = 120
        parent = 0x0
#2  __talloc (tc=<synthetic pointer>, size=24, context=0x1) at ../talloc.c:804
No locals.
#3  _talloc_named_const (name=0x7fd781255300 <Address 0x7fd781255300 out of bounds>, size=24, context=0x1) at ../talloc.c:961
        tc = <optimized out>
#4  talloc_named_const (context=<optimized out>, size=24, name=0x7fd781255300 <Address 0x7fd781255300 out of bounds>) at ../talloc.c:1728
No locals.
#5  0x00007fd781243dd0 in ?? ()
No symbol table info available.
#6  0x000055b88ed38ac0 in ?? ()
No symbol table info available.
#7  0x0000000000000000 in ?? ()
No symbol table info available.

(gdb) frame 1
#1  __talloc_with_prefix (tc_ret=<synthetic pointer>, prefix_len=0, size=24, context=0x1) at ../talloc.c:743
743			parent = talloc_chunk_from_ptr(context);

(gdb) set print pretty on
(gdb) p *talloc_chunk_from_ptr
$1 = {struct talloc_chunk *(const void *)} 0x7fd78d3bd6f0 <talloc_chunk_from_ptr>



# less package
sssd-common-1.16.2-13.el7

Comment 8 Jakub Hrozek 2019-03-13 22:23:21 UTC

*** This bug has been marked as a duplicate of bug 1683946 ***


Note You need to log in before you can comment on or make changes to this bug.