Bug 165281 - Screen corruption when running full-screen VMware under DRI-enabled XFree86
Screen corruption when running full-screen VMware under DRI-enabled XFree86
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-06 13:38 EDT by Topski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-26 16:32:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Topski 2005-08-06 13:38:07 EDT
I am having exactly the same problem with my Dell D400 laptop, containing a i852
(intel) chipset. When I run VMWare (v4.52) sessions in normal mode (windowed),
there are no problems at all. It only happens running full screen sessions.

Is there an 'understandable' solution for this ? I run Fedora Core 4 with latest
updates/fixes etc.

Thanks,

+++ This bug was initially created as a clone of Bug #73678 +++

Description of Problem:

On an ATI R128/Radeon i386 platform, when running the VMware emulator
(http://www.vmware.com) in full-screen mode within a DRI-enabled XFree86
session, screen corruption occurs in the vicinity of the mouse pointer.
As this is due to a bug in the XFree86 DRI code, other applications may be
affected too.


Version-Release number of selected component (if applicable):

XFree86 4.2.x, all versions.


How Reproducible:

Always.


Steps to Reproduce:
1. Enable DRI, start Xfree86 
2. Start VMware session, run in full-screen
3. Drag Windows windows with mouse, scroll windows, etc.


Actual Results:

The screen gets cluttered.


Expected Results:

No screen corruption.


Additional Information:
	
As VMware is a well-known and widely used application, and the ATI chipsets are
quite commoditized, I would expect this problem to have a wide impact.

Fortunately, as of today, Mr. Michel Daenzer posted a patch which finally fixes
this problem (tested on an IBM ThinkPad A30p, ATI Radeon Mobility M6).

http://www.geocrawler.com/lists/3/SourceForge/680/0/9539606/

Patch against XFree86 4.2 attached (courtesy of Mr. Daenzer).
Comment 1 Mike A. Harris 2005-08-30 11:32:54 EDT
Please don't hit the "clone bug" button for issues like this.  There is very
little similarity between the bug you cloned and the likely problem you
are experiencing.  Always file brand new bug reports detailing your specific
problem, and if you think another bug is similar or related, or might
contain useful info, then put a hyperlink to the other bug(s) for reference.

Aside from that though, you're asking only tech support questions rather
than filing a real bug report.  X.Org mailing lists are better suited to
such technical support questions.  Bugzilla is not for technical support.

If you believe you are experiencing a bug in X.Org, then please report
VMware related issues directly to X.Org developers by filing
a bug report in the X.Org bugzilla located at http://bugs.freedesktop.org
in the "xorg" component.  VMware developers currently maintain the "vmware"
driver in X.Org, and handle all vmware related bug reports.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.
Comment 2 Mike A. Harris 2005-09-26 16:32:46 EDT
We've requested an X.Org bug report URL for this issue, however
it's been almost a month and nobody has provided a URL.  As such,
we are unable to track this issue any further.

If someone files a bug in X.Org bugzilla, and would like Red Hat to
track the issue, please feel free to paste the URL here, and reopen
the bug.

Thanks.

Setting status to "WONTFIX"

Note You need to log in before you can comment on or make changes to this bug.