Bug 1652811 - The "SILENCED ALERTS" are all 0 for Expired and Pending silence
Summary: The "SILENCED ALERTS" are all 0 for Expired and Pending silence
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Frederic Branczyk
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-23 06:47 UTC by Junqi Zhao
Modified: 2019-06-04 10:41 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
the "Affected alerts" is "No silenced alerts" in alertmanager UI for active silence (61.92 KB, image/png)
2018-11-23 06:47 UTC, Junqi Zhao
no flags Details
The "SILENCED ALERTS" are all 0 for Expired and Pending silence in console UI (113.53 KB, image/png)
2018-11-23 06:48 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:08 UTC

Description Junqi Zhao 2018-11-23 06:47:03 UTC
Created attachment 1508215 [details]
the "Affected alerts" is "No silenced alerts" in alertmanager UI for active silence

Description of problem:
This bug is cloned from https://jira.coreos.com/browse/MON-477
File it again for QE team to track the monitoring issue.


The "SILENCED ALERTS" are all 0 for Expired and Pending silence, see the attached picture SILENCED_ALERTS.png.
Only the "SILENCED ALERTS" for Active silence is not 0

Maybe it is related to https://jira.coreos.com/browse/MON-463

Tested with images
docker.io/grafana/grafana:5.2.4
docker.io/openshift/oauth-proxy:v1.1.0
docker.io/openshift/prometheus-alertmanager:v0.15.2
docker.io/openshift/prometheus-node-exporter:v0.16.0
docker.io/openshift/prometheus:v2.5.0
quay.io/coreos/configmap-reload:v0.0.1
quay.io/coreos/kube-rbac-proxy:v0.4.0
quay.io/coreos/kube-state-metrics:v1.4.0
quay.io/coreos/prom-label-proxy:v0.1.0
quay.io/coreos/prometheus-config-reloader:v0.25.0
quay.io/coreos/prometheus-operator:v0.25.0
quay.io/openshift/origin-cluster-monitoring-operator:v4.0

 

I am a little confused  about the Active silence, the "SILENCED ALERTS" number is not 0 in console UI, does the value not get from alertmanager?

Since https://jira.coreos.com/browse/MON-463

the "Affected alerts" is "No silenced alerts" in alertmanager UI, see the attached picture active_silence_in_alertmanager.png


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Check all the silences in console UI by clicking "Monitoring -> Silences"
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Junqi Zhao 2018-11-23 06:48:30 UTC
Created attachment 1508216 [details]
The "SILENCED ALERTS" are all 0 for Expired and Pending silence in console UI

Comment 2 Junqi Zhao 2019-01-17 06:33:55 UTC
Close this defect since the cloned one https://jira.coreos.com/browse/MON-477 is fixed

Comment 5 errata-xmlrpc 2019-06-04 10:41:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.