Bug 1652820 - vers=default is misleading when we mount without mentioning version
Summary: vers=default is misleading when we mount without mentioning version
Keywords:
Status: CLOSED DUPLICATE of bug 1588912
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cifs-utils
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ronnie Sahlberg
QA Contact: xiaoli feng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-23 07:43 UTC by Vijay Avuthu
Modified: 2018-11-26 09:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-26 09:29:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1653211 None CLOSED Fix incorrect default mount protocol version for vers= option in mount.cifs(8) manual page 2019-09-17 09:26:31 UTC

Internal Links: 1653211

Description Vijay Avuthu 2018-11-23 07:43:57 UTC
Description of problem:

When we mount the CIFS protocol without mentioning version, it autonegotiated to the highest supported version of SMB2/3 but when we check the from "mount" command it still shows the default version ( which is version 1.0 from man page )

Version-Release number of selected component (if applicable):

RHEL7.6

# rpm -qa | grep -i kernel
kernel-tools-libs-3.10.0-957.el7.x86_64
kernel-headers-3.10.0-957.el7.x86_64
kernel-3.10.0-957.el7.x86_64
kernel-tools-3.10.0-957.el7.x86_64
# 

How reproducible: Always


Steps to Reproduce:

1. mount the gluster volume with CIFS protocol

# mount -t cifs -o username=root,password=foobar \\\\<IP of Gluster>\\gluster-testvol_replicated /mnt/testvol_replicated_cifs

2. check the version 

# mount | grep -i cifs
\\<IP of Gluster>\gluster-testvol_replicated on /mnt/testvol_replicated_cifs type cifs (rw,relatime,vers=default,cache=strict,username=root,domain=,uid=0,noforceuid,gid=0,noforcegid,addr=<IP of Gluster>,file_mode=0755,dir_mode=0755,soft,nounix,serverino,mapposix,rsize=1048576,wsize=1048576,echo_interval=60,actimeo=1)
# 

3. In above o/p, vers=default which is misleading the user. It should show the correct version

Actual results:

vers=default which is misleading the user


Expected results:

vers=default which is misleading the user. It should show the correct version

Additional info:

Comment 2 xiaoli feng 2018-11-26 01:58:52 UTC

*** This bug has been marked as a duplicate of bug 1588912 ***

Comment 4 xiaoli feng 2018-11-26 07:29:02 UTC
> Can we keep bug it open to track the necessary changes required in man
> mount.cifs(8) to reflect this auto negotiation mechanism? As of now it is
> misleading to state that v1.0 is the default even though it is not used.
> Accordingly bug summary can be adjusted to convey the intend.

Yes, we can. I will re-open it. But I think it's clearer that file a new bug about the description for "vers" in man mount.cifs(8). Such as "The default since v4.13.5 is for the client and server to negotiate the highest possible version greater than or equal to 2.1. In kernels prior to v4.13, the default was 1.0. For kernels between v4.13 and v4.13.5 the default is 3.0.".

Thanks.


Note You need to log in before you can comment on or make changes to this bug.