Bug 1652826 - Failed to disable the python27 module.
Summary: Failed to disable the python27 module.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: python27-2.7-module
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Python Maintainers
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-23 08:10 UTC by Liu Song
Modified: 2018-11-26 19:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-26 19:52:58 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Liu Song 2018-11-23 08:10:11 UTC
Description of problem:
Failed to disable the python27 module.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
Beta 1.7 -- RHEL8.0 -- x86_64
[root@dell-r730-002-guest01 ~]# dnf module list python27 
Updating Subscription Management repositories.
Updating Subscription Management repositories.
Last metadata expiration check: 0:10:02 ago on Fri 23 Nov 2018 02:58:52 AM EST.
Red Hat Enterprise Linux 8 for x86_64 - AppStream HTB (RPMs)
Name                                  Stream                               Profiles                                 Summary                                                              
python27                              2.7 [d]                              default [d]                              Python programming language, version 
2.7

[root@dell-r730-002-guest01 ~]# dnf module disable python27 
Updating Subscription Management repositories.
Updating Subscription Management repositories.
Last metadata expiration check: 0:10:27 ago on Fri 23 Nov 2018 02:58:52 AM EST.
Error: Problems in request:
Modular dependency problems:

 Problem 1: module inkscape:0.92.3:20181015124405:77fc8825-0.x86_64 requires module(python27:2.7), but none of the providers can be installed
  - conflicting requests
  - module python27:2.7:20181016151658:43711c95-0.x86_64 is disabled
 Problem 2: module mercurial:4.6:20180813043800:77fc8825-0.x86_64 requires module(python27:2.7), but none of the providers can be installed
  - conflicting requests
  - module python27:2.7:20181016151658:43711c95-0.x86_64 is disabled
 Problem 3: module gimp:2.8:20180912094043:77fc8825-0.x86_64 requires module(python27:2.7), but none of the providers can be installed
  - conflicting requests
  - module python27:2.7:20181016151658:43711c95-0.x86_64 is disabled
 Problem 4: module mailman:2.1:20181008090351:77fc8825-0.x86_64 requires module(python27:2.7), but none of the providers can be installed
  - conflicting requests
  - module python27:2.7:20181016151658:43711c95-0.x86_64 is disabled                             
Hint: [d]efault, [e]nabled, [x]disabled, [i]nstalled

Actual results:
Failed to disable the python27 module.

Additional info:

Comment 1 Tomas Orsava 2018-11-26 19:52:58 UTC
This is not a bug, but a feature of DNF: You cannot disable a module if enabled modules depend on it. It makes sense, because you would break dependencies.

What you can do instead is disable python27 and all the modules that depend on it (see below).

Closing as not-a-bug, but please let me know if I can help you further.



# yum module disable python27 mailman mercurial inkscape gimp
...
Disabling module streams:
 gimp                                                                                                                    
 inkscape                                                                                                                
 mailman                                                                                                                 
 mercurial                                                                                                               
 python27                                                                                                                

Transaction Summary
===========================================================

Is this ok [y/N]: y
Complete!


Note You need to log in before you can comment on or make changes to this bug.